Bug 242089 - Startup hangs at "starting system message bus" if ldaps authentication enabled in firstboot
Summary: Startup hangs at "starting system message bus" if ldaps authentication enable...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-01 16:20 UTC by Gordon Messmer
Modified: 2014-09-16 11:56 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:21:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gordon Messmer 2007-06-01 16:20:50 UTC
People were describing too many problems in the original bug.  Under RHEL5, if
you configure the system to use LDAP as an NSS source, the "messagebus" service
will hang during boot.   This is caused by a calling initgroups() for the dbus
user, which attempts to query LDAP to determine whether the dbus user is a
member of any groups stored there.  The situation is resolved if:

nss_initgroups_ignoreusers root,ldap,named,avahi,haldaemon

becomes:

nss_initgroups_ignoreusers root,ldap,named,avahi,haldaemon,dbus

Comment 1 Gordon Messmer 2008-10-11 02:06:50 UTC
It looks like this bug has been fixed, either in nss_ldap-253-13.el5_2.1 or a previous package.

Comment 2 Pierre Ossman 2009-03-07 18:46:54 UTC
Shouldn't this be closed or marked as a duplicate of bug 186527? (it's even got the exact same subject)

Comment 4 RHEL Product and Program Management 2014-03-07 13:53:06 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 5 RHEL Product and Program Management 2014-06-02 13:21:47 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 6 Gordon Messmer 2014-09-15 16:51:07 UTC
This comment is intended only to clear the needinfo status on this closed ticket.


Note You need to log in before you can comment on or make changes to this bug.