This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 242090 - Acer Aspire 1692 does not resume from suspend
Acer Aspire 1692 does not resume from suspend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 12:35 EDT by Daniel Qarras
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-28 12:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
hal-info patch for Acer Aspire 1692 suspend (891 bytes, patch)
2007-06-01 14:23 EDT, Daniel Qarras
no flags Details | Diff

  None (edit)
Description Daniel Qarras 2007-06-01 12:35:33 EDT
After default Fedora 7 installation on my Acer Aspire 1692 I suspended my
machine from System->Suspend. Everything seemed to went fine, machine was
stopped ok. But after hitting a button machine is powered on but nothing seems
to happen even if waiting like 10 minutes. The system does not react to any
attempts from keyboard (such as ctrl+alt+bs or ctrl+alt+del).

Only thing in /var/log/messages is:

Jun  1 19:17:04 localhost gnome-power-manager: (dqarras) Suspending computer
because user clicked suspend from tray menu
Comment 1 Daniel Qarras 2007-06-01 13:06:55 EDT
Actually, when suspending from console with

echo -n mem > /sys/power/state

system is suspended ok and resume fails again but now the system responds to
ctrl+alt+del or the command reboot. So the problem is that the display stays
disconnected.

This is probably related to Bug 236223.
Comment 2 Doncho N. Gunchev 2007-06-01 13:38:24 EDT
Does 'pm-suspend --quirk-vbe-post' (or any other option from pm-suspend --help)
from console help? If so I can help you create a patch for hal-info.
Comment 3 Doncho N. Gunchev 2007-06-01 13:43:40 EDT
btw: Get pm-utils-0.99.3-6.fc8.i386.rpm from koji.fedoraproject.org and install
that (rpm -Uhv pm-utils-0.99.3-6.fc8.i386.rpm), the f7 package has no vbetool
(should be fixed soon I think).
Comment 4 Daniel Qarras 2007-06-01 14:23:01 EDT
Created attachment 155916 [details]
hal-info patch for Acer Aspire 1692 suspend
Comment 5 Daniel Qarras 2007-06-01 14:24:03 EDT
Fantastic, 'pm-suspend --quirk-vbe-post' works perfectly!

I've attached a patch to hal-info that works for Acer Aspire 1692. It uses just
the same quirks as Acer Aspire 1690.

Thanks!
Comment 6 Daniel Qarras 2007-06-01 14:42:35 EDT
Oh, it should be noted that I was using the RPM from

http://koji.fedoraproject.org/packages/pm-utils/0.99.3/6.fc8/i386/pm-utils-0.99.3-6.fc8.i386.rpm

The default Fedora 7 RPM did not work.

Thanks.
Comment 7 Daniel Qarras 2007-06-07 13:43:27 EDT
Actually, I noticed that only the RPM upgrade is needed as lshal reports:

root@localhost:~# lshal | grep Aspire
  smbios.system.product = 'Aspire 1690'  (string)
  system.hardware.product = 'Aspire 1690'  (string)
  system.product = 'Aspire 1690 Not Applicable'  (string)

So, the patch is withdrawn, do not apply.

And if you can, please close this bug as only the RPM upgrade is needed.
Comment 8 Jackie 2007-06-09 15:22:01 EDT
I have the same problem. I have F7 on a Dell Inspiron B130 and everything
suspends correctly, but when I bring it back up, I get this message on the
screen and goes no further:

audit(1181402594.472:9): avc: denied {search} for pid=3136 comm="alsactl"
name="root" dev=sda1 ino=9035137 scontext=system_u: system_r: alsa_t:s0
tcontext=system_u: object_r: default:s0 tclass=dir
stopping tasks... done.
shrinking memory... done.
freed 74028 kbytes in 0.17 seconds (435.45 MB/s)
Suspending console(s)

I have disabled SElinux and still get the same result. I have not tried to kill
 "alsactl" before suspending, so that might be an easy fix. Will report back
with result at a later time.
Comment 9 Doncho N. Gunchev 2007-06-09 17:52:22 EDT
(In reply to comment #8)
> I have the same problem. I have F7 on a Dell Inspiron
...
> audit(1181402594.472:9): avc: denied {search} for pid=3136 comm="alsactl"
> name="root" dev=sda1 ino=9035137 scontext=system_u: system_r: alsa_t:s0
> tcontext=system_u: object_r: default:s0 tclass=dir
...
> I have disabled SElinux and still get the same result. I have not tried to 
kill
>  "alsactl" before suspending, so that might be an easy fix. Will report back
> with result at a later time.

You can not kill alsactl, it's started to restore the sound card settings (not 
a daemon). Do you have SELinux disabled or in permissive mode 
(/etc/sysconfig/selinux)?
Comment 10 Jackie 2007-06-12 13:44:29 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > I have the same problem. I have F7 on a Dell Inspiron
> ...
> > audit(1181402594.472:9): avc: denied {search} for pid=3136 comm="alsactl"
> > name="root" dev=sda1 ino=9035137 scontext=system_u: system_r: alsa_t:s0
> > tcontext=system_u: object_r: default:s0 tclass=dir
> ...
> > I have disabled SElinux and still get the same result. I have not tried to 
> kill
> >  "alsactl" before suspending, so that might be an easy fix. Will report back
> > with result at a later time.
> 
> You can not kill alsactl, it's started to restore the sound card settings (not 
> a daemon). Do you have SELinux disabled or in permissive mode 
> (/etc/sysconfig/selinux)?

Resume from hibernate works for me once I set SELinux to either permissive mode
or disabled. Once I put it back in enforce mode, I get the same message as
before. Don't know  why I didn't think of doing that before, but thanks for the
help anyhow.
Comment 11 Daniel Qarras 2007-10-19 11:18:25 EDT
I can confirm again that this is fixed in F8T3 & Rawhide. Feel free to close
this one.

Note You need to log in before you can comment on or make changes to this bug.