Bug 242114 - No MGA driver for PPc
No MGA driver for PPc
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-mga (Show other bugs)
5.0
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 15:22 EDT by Matthew Saltzman
Modified: 2007-12-18 18:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 18:25:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2007-06-01 15:22:02 EDT
Description of problem:
The xorg-x11-drv-mga RPM does not exist with architecture ppc.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.2-5.el5

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL5 on a PPC with MGA video.
2. Start X.
3.
  
Actual results:
MGA driver not loaded.  Max resolution 640x480.

Expected results:
MGA driver loaded.  Higher resolution available.

Additional info:
Comment 1 Jarod Wilson 2007-06-01 16:08:26 EDT
The video card in the IBM eServer under my desk would appear to benefit from the addition of this 
driver for ppc64 as well...

32:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 85) (prog-if 00 [VGA])
        Subsystem: IBM Unknown device 0233
        Flags: medium devsel, IRQ 36
        Memory at 100c0000000 (32-bit, prefetchable) [size=32M]
        Memory at 100c2800000 (32-bit, non-prefetchable) [size=8M]
        Memory at 100c2000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at 100c3000000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0
Comment 2 Jarod Wilson 2007-06-01 16:48:30 EDT
Hrm. I convinced the latest el5 xorg-x11-drv-mga driver to build for ppc[1], altered my xorg.conf to use 
mga, bounced X, and now the box is locked up (and I'm nowhere near it atm)...


[1] Needed to add something along the lines of --with-module-dir=%{moduledir} to get the module to 
end up in /usr/lib/xorg/modules instead of /usr/lib64/xorg/modules, even when passing in ppc as the 
target.
Comment 3 Yan Li 2007-06-04 05:08:15 EDT
Yeah, without MGA driver the graphical display on some IBM POWER servers are
nearly unusable, the default "fbdev" driver is extremely slow. So I think the
severity should be higher. Those servers are shipped with Matrox G400/G450
display cards.

I wonder why RHEL5 doesn't include this, while RHEL4 worked very well on those
machines.
Comment 4 Matěj Cepl 2007-09-03 12:39:19 EDT
If this is so serious problem, shouldn't it come through IssueTracker? I guess,
at least Yan, you could file it there.

For official Red Hat Enterprise Linux support, please log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket,
or alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1
to speak directly with a support associate and escalate an issue.
Comment 5 Yan Li 2007-09-04 04:23:34 EDT
OK, thanks Matej!  I'll report it to our sys admin to escalate it later.  But I
see no further info I can provide here, and since I'm not the bug reporter, I'll
change it's status, to avoid being blocked by me.
Comment 6 Adam Jackson 2007-12-18 18:25:23 EST
You can not effectively use the mga driver on most IBM POWER machines.  The X
server internally stores bus addresses as host-sized pointers.  As can be seen
in comment #1, the system BIOS assigns bus resources above the first 4G of
address space, which means host pointers aren't big enough to point into them. 
We use fbdev on these machines precisely for this reason.

There is work being done in upstream Xorg to fix this, but it will not ever make
it into RHEL5.  WONTFIX on that basis.

Note You need to log in before you can comment on or make changes to this bug.