Bug 242124 - [RHEL5.1][XEN][IA64] Fix HVM interrupts on IPF
[RHEL5.1][XEN][IA64] Fix HVM interrupts on IPF
Status: CLOSED DUPLICATE of bug 242125
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Keiichiro Tokunaga
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 16:23 EDT by Keiichiro Tokunaga
Modified: 2013-07-03 09:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 15:42:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keiichiro Tokunaga 2007-06-01 16:23:59 EDT
Description of problem:
Xen has changed to set-irq-level hypercall from shared-memory PIC stat.
IPF also needs to accomodate this.

cset#12441 fixes the issue.
Comment 2 RHEL Product and Program Management 2007-06-18 17:03:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2007-06-18 17:04:17 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 4 Don Zickus 2007-06-27 11:58:02 EDT
in 2.6.18-32.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 6 Red Hat Bugzilla 2007-07-24 20:47:29 EDT
change QA contact
Comment 7 Mike Gahagan 2007-09-19 16:36:06 EDT
The patch mentioned at :
http://post-office.corp.redhat.com/archives/rhkernel-list/2007-June/msg00843.html

is missing from the -45 kernel. Was there an alternate patch committed or was
this dropped intentionally?
Comment 8 Mike Gahagan 2007-09-19 16:40:37 EDT
It looks like the patch to fix bz242125 has pulled out the change mentioned in
comment 7. 
Comment 10 Don Zickus 2007-09-19 17:37:04 EDT
I see the same thing.  Kei what happened here?
Comment 11 Keiichiro Tokunaga 2007-09-20 11:03:27 EDT
That was done intentionally.  I posted 20 other patches when I post the patch 
for this bug.  And one of them replaced this patch [6/21].

  http://post-office.corp.redhat.com/archives/rhkernel-list/2007-
June/msg00847.html

Since we opened bugs for each cset of Xen upstream, we had to do the posting 
in such a confusable way...  (I understand it would be much better if we have 
combined the two for posting.)  Thank you for taking a careful look.
Comment 12 Keiichiro Tokunaga 2007-09-20 15:42:19 EDT
Talked with Brian.  As he sugguested, it would be more clear to treat this bug 
as a duplication of bz242125.  Closing this bug.

*** This bug has been marked as a duplicate of 242125 ***

Note You need to log in before you can comment on or make changes to this bug.