Bug 242138 - [RHEL5.1][XEN][IA64] dma-mapping.h user our own swiotlb.h header
[RHEL5.1][XEN][IA64] dma-mapping.h user our own swiotlb.h header
Status: CLOSED DUPLICATE of bug 217593
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Keiichiro Tokunaga
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 16:26 EDT by Keiichiro Tokunaga
Modified: 2013-07-03 09:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 15:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keiichiro Tokunaga 2007-06-01 16:26:26 EDT
Description of problem:
Need to change to include a generic swiotlb.h for ia64.  Without this fix, 
thrid party driver cannot be compiled.

cset#14056 fixes the issue.
Comment 2 RHEL Product and Program Management 2007-06-18 17:10:47 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 3 Don Zickus 2007-06-27 11:59:10 EDT
in 2.6.18-32.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 5 Red Hat Bugzilla 2007-07-24 20:49:20 EDT
change QA contact
Comment 6 Mike Gahagan 2007-09-25 15:07:29 EDT
This patch is essentially being removed by the
linux-2.6-xen-ia64-kernel-panics-when-dom0_mem-is-specified_2.patch

dma-mapping.h does include the file machvec.h which looks like it might have
some swiotlb related code within it. Can someone confirm this change was intended?
Comment 7 Keiichiro Tokunaga 2007-09-25 15:40:31 EDT
Yes.  That change was intended.  I posted the series of patches to the list 
and after that posted the following patch since we found an issue with the 
origianl patch for bz217593.
(http://post-office.corp.redhat.com/archives/rhkernel-list/2007-
June/msg01830.html)

  - linux-2.6-xen-ia64-kernel-panics-when-dom0_mem-is-specified_2.patch

This patch included "header clean up" portion that removed the changes you 
pointed out here.

As I did on other bug, I am closing this bug as duplication of bz217593.

*** This bug has been marked as a duplicate of 217593 ***

Note You need to log in before you can comment on or make changes to this bug.