Bug 24215 - When ftpcopy doesn't work, it doesn't write an error message
Summary: When ftpcopy doesn't work, it doesn't write an error message
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ftpcopy   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-17 15:48 UTC by David Lawrence
Modified: 2007-03-27 03:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 19:53:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Tattersall 2001-01-17 15:48:59 UTC
when ftpcopy fails to copy a directory due to, for instance, no anonymous
ftp server on the  host, ftpcopy silently reports a return code of 1, but
does not write any helpful message to stderr.  On success, it writes plenty
messages about what is copied.

Comment 1 Bernhard Rosenkraenzer 2001-01-17 19:51:55 UTC
I've pointed the base package maintainer to this bug report.

Comment 2 Bernhard Rosenkraenzer 2001-01-19 15:01:10 UTC
Please reopen this if you can provide a test case; this isn't happening here.
ftpcopy -u user.does.not.exist -p testing ftp://ftp.redhat.de/ test
ftpcopy: USER response: 530 Login incorrect.
ftpcopy ftp://csl11.nrw.net/ test
ftpcopy: USER response: 530 User anonymous access denied


Comment 3 Need Real Name 2001-03-26 19:49:47 UTC
ftpcopy used to exit with code 1 and without any error message if
the remote directory to be copied is completely empty. This has been
changed for version 0.3.6 (it will exit 0).


Note You need to log in before you can comment on or make changes to this bug.