Bug 242164 - Gnome/Kde under XEN does not always start after executon of startd
Gnome/Kde under XEN does not always start after executon of startd
Product: Fedora
Classification: Fedora
Component: kernel-xen-2.6 (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Eduardo Habkost
FC& XEN is stuck Starting GNOME
Depends On:
  Show dependency treegraph
Reported: 2007-06-01 17:51 EDT by Leslie Satenstein
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-21 20:26:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg showing boot activity (xen and non xen) (27.63 KB, text/plain)
2007-06-01 17:51 EDT, Leslie Satenstein
no flags Details
Messages log (466.77 KB, text/plain)
2007-06-01 17:54 EDT, Leslie Satenstein
no flags Details
Xorg.0.log (25.84 KB, text/plain)
2007-06-01 17:54 EDT, Leslie Satenstein
no flags Details
xorg/0.log.old (52.23 KB, text/plain)
2007-06-01 17:56 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2007-06-01 17:51:22 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install XEN kernel on appropriate hardware (Intel all the way)
2. Reboot, chosing XEN kernel 
Actual results:
First two times after installation, XEN worked fine, and I congratulated the
support/developers for having it solved for FC7. Thereafter, on further testing,
I can start XEN to where startd completes. At this point, I get no GNOME or KDE
startup (regular or root user)

Expected results:

Would like to use XEN. Have been waiting for a bug fix since November 2006 and
under FC6.  I am attaching dumps of dmesg, messages, and Xorg logs.

Additional info:

I have a two disk system, therefore the logs are the ones created from system 2
after system FC7 failed. (There was some deletion that I did for information
before the last executions). That is to keep the log files more pertenant.
Comment 1 Leslie Satenstein 2007-06-01 17:51:22 EDT
Created attachment 155944 [details]
dmesg showing boot activity (xen and non xen)
Comment 2 Leslie Satenstein 2007-06-01 17:54:13 EDT
Created attachment 155945 [details]
Messages log
Comment 3 Leslie Satenstein 2007-06-01 17:54:55 EDT
Created attachment 155946 [details]
Comment 4 Leslie Satenstein 2007-06-01 17:56:55 EDT
Created attachment 155947 [details]
Comment 5 Leslie Satenstein 2007-06-01 18:06:09 EDT
root stuff, everything looks clean.

-rw-r--r-- 1 root root  310270 May 22 08:51 xen.gz-2.6.20-2925.9.fc7
-rw-r--r-- 1 root root 2191265 May 22 08:58 vmlinuz-2.6.20-2925.9.fc7xen
-rw-r--r-- 1 root root  875161 May 22 08:58 System.map-2.6.20-2925.9.fc7xen
-rw-r--r-- 1 root root   67658 May 22 08:58 config-2.6.20-2925.9.fc7xen
-rwxr-xr-x 1 root root  780398 May 22 08:59 xen-syms-2.6.20-2925.9.fc7
-rw-r--r-- 1 root root 1883604 May 23 22:40 vmlinuz-2.6.21-1.3194.fc7
-rw-r--r-- 1 root root  917777 May 23 22:40 System.map-2.6.21-1.3194.fc7
-rw-r--r-- 1 root root   75649 May 23 22:40 config-2.6.21-1.3194.fc7
drwx------ 2 root root   12288 May 31 16:29 lost+found
-rw------- 1 root root 3567085 May 31 16:45 initrd-2.6.21-1.3194.fc7.img
-rw------- 1 root root 3577051 Jun  1 16:33 initrd-2.6.20-2925.9.fc7xen.img
drwxr-xr-x 2 root root    1024 Jun  1 16:33 grub

Here is my stupid 2 cents worth. Since startd is the last program executing, can
someone make a patched version of a sesstion that would follow startd and would
serve to take a snapshot of the system at this point in time, just before
control is turned over to GNOME. 

And I thought I could start virtual XEN testing... 

Here again.. to save time for you 
Intel environment
Mother Board d945gnt (no pci, no external video -- using built-in)
Processors   intel d930
memory       1 gig
Hard disk    maxtor ide 200 gig, with about 100 gig free.

The bios version on the mother board is the one that is currently on the intel
web site. (Version 4078 dated April 5, 2007)
Comment 6 Leslie Satenstein 2007-06-01 18:28:00 EDT
Further testing

Keyboard and mouse are locked out. Keyboard lights do not reflect shift key test, 
ctl-alt-backspace inneffective.
Mouse has no cursor and is not responsive. (The screen is black).

Please raise the priority from low to high. 

Comment 7 Leslie Satenstein 2007-06-03 11:55:38 EDT
Works fine with 64bit version. One can say, not at all with 32bit version
Comment 8 Leslie Satenstein 2007-06-21 20:26:49 EDT
Since last xen update (past 31may 2007, it works for me)

Note You need to log in before you can comment on or make changes to this bug.