Bug 242186 - ata_piix not autoloaded
Summary: ata_piix not autoloaded
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 01:11 UTC by Bradley
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-29 09:53:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -n (633 bytes, text/plain)
2007-06-02 01:11 UTC, Bradley
no flags Details

Description Bradley 2007-06-02 01:11:27 UTC
Description of problem:

I have an Toshiba Tecra S3 laptop, with an ICH6 chipset. theres a SATA hard
drive an a PATA ATAPI dvd drive.

The DVD drive is supported by ata_piix, but that driver is autoloaded. I have to
modprobe it in. Then, to actually use the dvd I have to modprobe sr_mod; it
looks like the udev rule to do that isn't working

Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3194.fc7
udev-106-4.fc7

How reproducible:

Always

Steps to Reproduce:
1. Run F7 on a Toshiba Tecra S3

Actual results:

DVD not detected

Expected results:

DVD detected and modules loaded

Additional info:

Anaconda does pick up the DVD drive, after manually selecting the driver. I did
have to add |noprobe| to the anaconda boot options - see bug 215016? Unsure if
thats related. This was an FC6 upgrade, FWIW.

lspci -n is attached.

/sys/devices/pci0000:00/0000:00:1f.1/host4/target4:0:0/4:0:0:0/type is 5, so the
udev rule should be triggering

Comment 1 Bradley 2007-06-02 01:11:27 UTC
Created attachment 155958 [details]
lspci -n

Comment 2 Harald Hoyer 2007-06-04 09:46:16 UTC
You mean, ata_piix is _not_ loaded automatically? And sr_mod not also?

Comment 3 Bradley 2007-06-04 09:50:39 UTC
Err, yeah, sorry. And sr_mod isn't loaded automatically at boot, or on modprobe
of ata_piix

FWIW, ata_piix is not needed for bootup - the hard drive here is SATA, using the
ahci driver

Comment 4 Bradley 2007-06-29 09:53:22 UTC
Worked this out - ata_piix was blacklisted due to the FC6 version of bug 215016
causing ata_piix to load instead of ahci, rather than as well as.

Oops...


Note You need to log in before you can comment on or make changes to this bug.