Bug 24221 - X-server nonstart detection recovery fallback code
X-server nonstart detection recovery fallback code
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Florence Beta-3
:
: 24644 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 12:18 EST by R P Herrold
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-03 18:52:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2001-01-17 12:18:54 EST
Date: Wed, 17 Jan 2001 11:57:59 -0500 (EST)
From: herrold <herrold@owlriver.com>
To: Redhat Testers <testers-list@redhat.com>
Subject: [testers] 2 failed install report- Beta 2
 
HP NetServer 4s/66 LM - 64 M, SCSI CD and drives, Adaptec AIC7xxx
controller. onboard VGA, 3-com 3x509 NIC, PS/2 mouse plugged into
the onboard mouse jack, next to PS/2 keyboard jack
 
(Unit was currently running RH 6.1)
-------------------------------
 
Booted from a floppy containing ./images/boot.img, and confirmed
detect of AIC-7xxx driver
 
Never left text mode - traceback still visible on screen is:    
-------------------------------
(manual transcription)
 
File /usr/tmp/anaconda-7.1/usr/lib/anaconda/xf86config.py, line
1020, in test
   serverPath = "/usr/X11R5/bin" + self.server
TypeError illegal agrument type for built-in operation
 
tested the x server
Waiting for X server to start.Traceback (innermost list_
  File "usr/bin/anaconda", line 279, in ?
    result = xserver.startX (runres)
  File "/usr/lib/anaconda/xserver.py". line 125, in startX
    testx(mouse, x)
  File "/usr/lib/anaconda/xserver.py", line 156, in testx
    pid, status = os.waitpid (server, os.WNOHANG)
  install exited abnormally
 
... and so on.  This was a 'hit enter' isntall -- I will retry
explicitly 'text'
 
-----------------------   

(Addendum -- which works fine ...-- Russ)

  NameError: server
Comment 1 Glen Foster 2001-01-17 13:17:32 EST
This defect is considered MUST-FIX for Florence Beta-3
Comment 2 Michael Fulbright 2001-01-17 13:18:30 EST
What is the onboard VGA chipset?
Comment 3 R P Herrold 2001-01-17 14:15:56 EST
If there is an interim fix, before B3 which you wish me to test with this hardware, let me knoiw, and I'll try it out -- this host is at my office, and otherwise unused at the moment.
Comment 4 R P Herrold 2001-01-17 14:53:21 EST
-- host was hosed in an upgrade -- see 24233, which
seems to have mailed to you as well.
 
I am re-installing. to access /proc/pci to get the card spec for you.
Comment 5 Michael Fulbright 2001-01-17 18:52:57 EST
User reports:

        Chipset: WD/Paradise 90C31 (Port Probed)
        Memory:  512 Kbytes
        RAMDAC:  AT&T 20C493 15/16/18-bit DAC
                 (with 6-bit wide lookup tables (or in 6-bit mode))


Comment 6 Michael Fulbright 2001-01-17 18:55:54 EST
Is this an ISA video card?
Comment 7 R P Herrold 2001-01-17 22:09:03 EST
No -- This is the onboard video chip for a HP NetServer HP 4/66LM
... which is an EISA bus host.  It has an onboard AIC-7xxx compatible Adaptec
controller.  I snagged an image off ebay of a slightly earlier
model, and have posted it at:
http://clone.iwaynet.net/hp/HP-netserver-LH-466-motherboard.jpg

Hope this makes it clearer ...
Comment 8 Michael Fulbright 2001-01-18 11:38:54 EST
So a text mode install works?

Does Xconfigurator properly configure the graphics card?
Comment 9 R P Herrold 2001-01-18 13:59:56 EST
RH 7.1B2 text mode installs fine without even need to use driver disk to
get the AIC-7xxx module -- This is improved from 7.0 beta 2 which
did NOT find the SCSI controller signature.

The 7.1B2 text install did not auto prompt for X setup ... I ran
Xconfigurator manually later -- it did not identify the chipset automatically -
I manually gave it UNLISTED VGA, since I do not use X on this host,
except with a remote display through a SSH tunnel

-- Russ
Comment 10 Glen Foster 2001-01-18 16:26:01 EST
This defect is considered MUST-FIX for Florence Beta-3
Comment 11 Matt Wilson 2001-01-19 00:43:57 EST
herrold - is this fixed for you?
Comment 12 R P Herrold 2001-01-19 00:55:49 EST
No -- What fix has been suggested? -- Text mode is a fallback - Xcon
does NOT find the chip.  SuperProbe can dump the chip info - use its
detect logic in X driver selection, or something similar. --
The error recovery code in anaconda is dying on the results of the
traceback I posted.  This needs a error return check at the line
where it dies to cover this case.
This seems to still be well and truly unfixed.

If there is an updated anaconda, point me at it, and I will pull
and test ...
Comment 13 Brent Fox 2001-01-19 12:45:53 EST
This bug is a dupe of #23439
Comment 14 Brent Fox 2001-01-19 16:25:12 EST
We've fixed this in our latest internal builds.  The installer should fall back
to text mode gracefully now instead of causing a traceback.  Thanks for your
report.
Brock, please verify that this has been fixed.  If you have some old video cards
that can't be probed, I'd recommend testing those and make sure they fall back
to text mode properly.

Comment 15 Brent Fox 2001-01-24 12:48:02 EST
*** Bug 24644 has been marked as a duplicate of this bug. ***
Comment 16 R P Herrold 2001-02-03 18:52:52 EST
I confirm that for my host, this fix worked ...

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=25927
Comment 17 R P Herrold 2001-03-01 20:56:33 EST
7.1RC1 --- still fine ...

Note You need to log in before you can comment on or make changes to this bug.