Bug 242225 - Network installation fails
Network installation fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
:
: 239284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 07:15 EDT by Jasper Siepkes
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 15:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper Siepkes 2007-06-02 07:15:50 EDT
Description of problem:
Network installation from FTP or HTTP (Haven't tried NFS) dies after the
stage2.img is downloaded successfully with:

19:45:46 ERROR : LOOP_SET_FD failed: Device or resource busy
19:45:46 ERROR : Error mounting /dev/loop0 in /mnt/runtime (Device or resource busy)

Version-Release number of selected component (if applicable):
11.0.2.66

How reproducible:
Boot from any Fedora 7 ISO (Be it the full DVD or the Rescue CD) and try to 
perform a network installation from FTP or HTTP.

Expected result:
After the stage2.img is downloaded it is successfully mounted to the loopback
device and stage 2 of the installer is started.
Comment 1 Jasper Siepkes 2007-06-02 07:17:39 EDT
Additional info can be found here:
http://forums.fedoraforum.org/showthread.php?t=156256
Comment 2 Jerry Marceau 2007-06-05 11:19:07 EDT
Some comments that may or may not be helpful

- I've only seen this on the x86_64 install DVD and rescue CD.  the i386 rescue
cd can do a network install (haven't tested the i386 DVD)
- For x86_64, You can use the boot.img image in the 'images' folder and the
network install will start and complete.  But the resulting install doesn't want
to boot, and I think it is due to a root on raid-1 problem but I need to do some
more testing to be sure.
Comment 3 David Cantrell 2007-08-23 15:24:09 EDT
*** Bug 239284 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2007-08-23 15:34:07 EDT
I've just performed HTTP installations on i386 and x86_64 for Fedora 8 Test 1
and this bug appears to have been fixed.  I think I fixed it, in fact.  I
remember working on this particular problem a couple of months ago.

Thanks for the reports.

Note You need to log in before you can comment on or make changes to this bug.