Bug 242231 - logrotate file is missing
Summary: logrotate file is missing
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tom Lane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 12:37 UTC by Vilius Šumskas
Modified: 2013-07-03 03:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-02 17:03:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vilius Šumskas 2007-06-02 12:37:09 UTC
Description of problem:
Logrotate file for MySQL in recent Fedora versions is missing.

Version-Release number of selected component (if applicable):
mysql-5.0.37-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Go to /etc/logrotate.d
  
Actual results:
File is not there and logrotate doesn't rotate MySQL logs which makes them 
bigger and bigger.

Expected results:
Logrotate should rotate MySQL log files.

Comment 1 Tom Lane 2007-06-02 17:03:11 UTC
That file was removed intentionally because it never worked, and never can work without invasive changes 
to the behavior of mysqld_safe; see bug #180639 and bug #72391 for prior discussions.

It's claimed upstream that it'll be possible to make it work as of mysql 5.1 (http://bugs.mysql.com/
bug.php?id=6061) but they don't want to back-port such a change and neither do I.


Note You need to log in before you can comment on or make changes to this bug.