Bug 242234 - Module b44 needs to be blacklisted for hibernate
Module b44 needs to be blacklisted for hibernate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
:
: 357711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 09:42 EDT by Bojan Smojver
Modified: 2008-02-07 14:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 14:28:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2007-06-02 09:42:38 EDT
Description of problem:
Without blacklisting b44 modules, thaw hangs on Dell Inspiron 6400.

Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Hibernate.
2. Thaw.
  
Actual results:
Kernel hangs.

Expected results:
This used to work in FC6.

Additional info:
Blacklisting the module works around the problem. Suspend doesn't work correctly
on this notebook (machine in painfully slow on resume), so I'm not using that at
all.
Comment 1 Nigel Cunningham 2007-06-12 06:53:44 EDT
Reassigning to pm-utils.
Comment 2 Timon 2007-12-07 01:13:51 EST
i checked it on f8 with kernel-2.6.23.8-63.fc8, and it seems kernel bug. with
b44 blacklisted everything is ok. with b44 loaded resume from suspend/hibernate
hang with black screen and no error messages

i tried kernel-2.6.24-0.73.rc4.git1.fc9. with this kernel my notebook HP nx6310
trying to resume from hibernate, but something goes wrong and it hangs :(

I don't know how to debug this problem
Comment 3 Timon 2007-12-17 00:13:17 EST
[timon@localhost ~]$ cat /etc/pm/config.d/unload_modules 
SUSPEND_MODULES="kvm_intel kvm iwl3945 b44"

this works for me
Comment 4 Till Maas 2008-01-08 11:49:20 EST
Imho the module should be fixed to make it work with hibernate, this needs to be
done in the kernel.
Comment 5 Christopher Brown 2008-01-08 19:53:17 EST
This is wireless so re-assigning as per:

http://fedoraproject.org/wiki/KernelBugTriage

It might also be worth testing with a rawhide kernel if you are able - as far as
I understand it this driver is still undergoing heavy development.

Cheers
Chris
Comment 6 John W. Linville 2008-01-09 08:57:45 EST
b44 is not wireless -- FYI

Still, it would probably come to me anyway.  So, I'll see what I can do...
Comment 7 J. Ali Harlow 2008-01-16 18:45:19 EST
*** Bug 357711 has been marked as a duplicate of this bug. ***
Comment 8 Andy Gospodarek 2008-01-22 16:06:30 EST
hmmmmm, tg3 had a problem with suspend/resume recently

commit 3e0c95fd648c0d3175b9ff2232597d0b02eb7d46
Author: Michael Chan <mchan@broadcom.com>
Date:   Fri Aug 3 20:56:54 2007 -0700

    [TG3]: Fix suspend/resume problem.

in that case a reload of the tg3 driver fixed all problems.

Maybe some ssb bus wrangling is needed in this case....
Comment 9 Timon 2008-01-29 06:27:16 EST
it seems this bug was fixed in 2.6.24, because fc8 with  2.6.24-2.fc9 kernel
suspend/hibernate and resume fine
laptop hp nx6310
Comment 10 John W. Linville 2008-02-07 14:28:13 EST
Closing as RAWHIDE based on comment 9

Note You need to log in before you can comment on or make changes to this bug.