Bug 242253 - kernel 2.6.21-1.3199.fc8 breaks hardware clock access
Summary: kernel 2.6.21-1.3199.fc8 breaks hardware clock access
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 18:45 UTC by Michal Jaegermann
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-10 19:25:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-06-02 18:45:07 UTC
Description of problem:

After booting with 2.6.21-1.3199.fc8, at least on x86_64 machine,
any attempt to run hwclock ends up with the following:

Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.

After 'hwclock --debug' I am seeing:

hwclock from util-linux-2.13-pre7
hwclock: Open of /dev/rtc failed, errno=19: No such device.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

although 'udev' clearly created /dev/rtc for whatever reasons.

Rebooting with 2.6.21-1.3194.fc7 or earlier immediately solves
the issue. Is the above an effect of "Rebase to 2.6.22rc3"?

Version-Release number of selected component (if applicable):
kernel 2.6.21-1.3199.fc8

How reproducible:
always

Comment 1 Michal Jaegermann 2007-06-03 17:50:46 UTC
The same issue with 2.6.21-1.3200.fc8.

Comment 2 Michal Jaegermann 2007-06-10 19:25:43 UTC
hwclock started to work again with kernel 2.6.21-1.3218.fc8.
An output from 'hwclock --debug --show' look currently like this:

hwclock from util-linux-2.13-pre7
Using /dev/rtc interface to clock.
Last drift adjustment done at 1181500588 seconds after 1969
Last calibration done at 1181500588 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
/dev/rtc does not have interrupt functions. Waiting in loop for time from
/dev/rtc to change
...got clock tick
Time read from Hardware Clock: 2007/06/10 18:42:40
Hw clock time : 2007/06/10 18:42:40 = 1181500960 seconds since 1969
Sun 10 Jun 2007 12:42:40 PM MDT  -0.129198 seconds

It should be noted that in dmesg there are traces that something
tries to access rtc before it is available:
....
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Freeing unused kernel memory: 312k freed
....
and only quite a bit later this shows up:
....
rtc_cmos 00:02: rtc core: registered rtc_cmos as rtc0
rtc0: alarms up to one year, y3k
....



Note You need to log in before you can comment on or make changes to this bug.