Bug 242261 - S/MIME certificate stopped working after upgrade FC6->F7
S/MIME certificate stopped working after upgrade FC6->F7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 16:08 EDT by Tomas Pecina
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-data-server-1.10.2-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 13:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pecina 2007-06-02 16:08:50 EDT
Description of problem:

S/MIME signing is broken in the new version shipped with F7. When I try to send
an S/MIME signed message, an error box pops us stating

Could not create message.
Because "Failed to encode data", you may need to select different mail options.

(which is somewhat difficult to understand)

and the message is not sent.

Version-Release number of selected component (if applicable):

both 2.10.1-4.fc7 and 2.11.2-1.fc8

How reproducible:

Always.

Steps to Reproduce:
1. Install an S/MIME in evolution used in FC6 and check signing.
2. Upgrade to F7.
3. Try to send an S/MIME signed e-mail.
  
Actual results:

Error box pops up, message not sent.

Expected results:

Message signed and sent.

Additional info:
Comment 1 Matthew Barnes 2007-06-02 17:18:34 EDT
Possibly related to bug #241974.
Changing the component based on that assumption.

Can you please try upgrading to evolution-data-server 1.10.2-2.fc7 or
1.11.2-3.fc8 and check if the problem still exists?
Comment 2 Tomas Pecina 2007-06-03 00:42:06 EDT
1.11.2-3.fc8 works as expected.
Comment 3 Aaron Hagopian 2007-06-06 13:18:54 EDT
I too have this problem.  I upgraded to 1.10.2-2.fc7 from updates-testing and
that also fixed the problem.
Comment 4 Matthew Barnes 2007-06-06 13:48:44 EDT
Got confirmation for both versions of the package, so I'm closing this bug.
Feel free to reopen this if you still encounter the problem.
Comment 5 Sergio Monteiro Basto 2007-06-12 21:38:45 EDT
3rd confirmation :)
after yum -y update --enablerepo=updates-testing evolution-data-server
I can send my email signed (with s/mime) as usual 
thanks, 

Note You need to log in before you can comment on or make changes to this bug.