Bug 242271 - HTTP installation hangs on package 585 of 713, 64%, openoffice.org-core (213MB)
HTTP installation hangs on package 585 of 713, 64%, openoffice.org-core (213MB)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
powerpc Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 17:46 EDT by Gideon Mayhak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 17:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gideon Mayhak 2007-06-02 17:46:23 EDT
Description of problem:
I have been attempting to get Fedora 7 installed on an older G3 iMac I picked up
at a garage sale.  The optical drive has stopped reading discs beyond about
halfway, whether CD or DVD, so I decided to do a net install using the boot.iso
image found in the /images/ folder at
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Fedora/ppc/os/.  I
originally tried doing this with the download.fedora.redhat.com mirror, with
which it froze twice (two tries) around the 60-some percent mark (I'm not sure
if it was this same package) and would proceed to say that the installer exited
improperly and that I could safely reboot.

I have now downloaded the DVD ISO, mounted it on my i386 desktop (running FC6),
and set up a simple HTTP server to pull this all from.  I have now booted from
the boot.iso disc twice, and both times it hangs on the package mentioned in the
summary.  The difference between the Internet install and the local HTTP install
is that the local install never gives me the above error; it just sits on the
package with occasional hard drive activity (I let it sit for nearly 3 hours the
first time, and it is sitting once again as I type this).

Version-Release number of selected component (if applicable):
Fedora 7 PPC DVD

How reproducible:
Twice using download.fedora.redhat.com as a mirror and twice with a local HTTP
server.

Steps to Reproduce:
Detailed above.  The only thing different I did from a default install was to
deselect GNOME and select XFCE for my desktop environment.  I have not tried a
completely default install, nor have I tried deselecting OpenOffice.org (I wish
to have only XFCE and I want to have OOo installed right away).  I will attempt
to do an install with OOo deselected, and I will update this bug report should
it hang on any other package.
  
Actual results:
Does not complete installation.

Expected results:
Continue on to next package and completes installation.

Additional info:
G3 iMac, 400MHz, 192MB RAM
Comment 1 Gideon Mayhak 2007-06-04 01:50:48 EDT
I have attempted to do the install with the Office/Productivity box unchecked,
and it did not hang on any other package.  I have also attempted a completely
default install, and it hangs on the openoffice.org-core package.  I gave it a
little over an hour before I just turned off the computer.  I calculated that a
213MB file would take less than 3 minutes to transfer at 10Mbps, and I can't see
it taking over 3 hours to install, so I'm guessing it has got to be a problem
with the package or the installer.

Could this be an issue with a default setting somewhere for Apache?  At the
moment, I have just left it at its default settings (because they seemed to work
perfectly).  I'm running the latest httpd from Fedora Core 6's repository.  It
doesn't seem likely, as it shouldn't take it so long to transfer the file that
it would time out, but it is also the largest package I noticed (though I wasn't
watching every one).

If I'm not the only one experiencing this kind of problem, then I hope it can be
worked out.  I'm just wondering what kind of fix would be made available, as I
don't know what your policy is on redoing a stable ISO release.  Please let me
know if there's anything I can try to help further troubleshoot this.

Thanks for any input/help,

Gideon Mayhak
Comment 2 Gideon Mayhak 2007-06-07 17:18:44 EDT
I configured a quick FTP server and tried doing it via FTP and it still froze on
the OOo package.  I have now burned the rescue CD (instead of just the boot.iso
disc) and it has made it past the package!  I don't know what it would've been,
but at least it's working with the rescue CD.  I know I didn't receive any
replies, but thanks anyway for this great distro!

Thanks again,

Gideon Mayhak
Comment 3 David Cantrell 2007-08-22 17:13:59 EDT
G3 iMacs are really really really old and slow for Fedora now.  I have one here
and I can only get it to install up to Fedora Core 5 and for that it takes about
12 to 14 hours.  And then it usually crashes.

I have heard reports of people installing FC4 or earlier and slowly using yum to
step it up through each release (4 to 5, 5 to 6, 6 to 7), but even then you have
to manually run yum and upgrade the packages in batches.  So it's doable, just
not by anaconda.

Can't fix this one.

Note You need to log in before you can comment on or make changes to this bug.