This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 242281 - yumdownloader cannot download kernel source
yumdownloader cannot download kernel source
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-02 19:21 EDT by Tom Horsley
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.1.6-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 13:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2007-06-02 19:21:35 EDT
Description of problem:

yumdownloader crashes when I try to download kernel source with it.

Version-Release number of selected component (if applicable):
yum-utils-1.1.4-1.fc7

How reproducible:
every time

Steps to Reproduce:
1.yumdownloader --enable fedora-source --source kernel-2.6.21-1.3194.fc7
2.
3.
  
Actual results:
Loading "installonlyn" plugin
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 190, in <module>
    util = YumDownloader()
  File "/usr/bin/yumdownloader", line 41, in __init__
    self.main()
  File "/usr/bin/yumdownloader", line 49, in main
    opts = self.doUtilConfigSetup()
  File "/usr/share/yum-cli/utils.py", line 69, in doUtilConfigSetup
    (opts, self.cmds) = self._parser.setupYumConfig()
  File "/usr/share/yum-cli/cli.py", line 1151, in setupYumConfig
    self.base._getRepos(doSetup=True)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 341, in _getRepos
    repo.setup(self.conf.cache, self.mediagrabber)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 634, in setup
    self.dirSetup()
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 439, in dirSetup
    "Cannot access repository dir %s" % dir
yum.Errors.RepoError: Cannot access repository dir //var/cache/yum/fedora-source


Expected results:

downloads source for kernel

Additional info:
Comment 1 Tim Lauridsen 2007-06-18 05:52:11 EDT
I can reproduce the issue, i have fixed it upstream, it will be available in
yum-utils 1.1.6.


I the meantime you can use:
sudo yumdownloader --source kernel
to get the source downloaded. 

HINT: You don't need '--enable fedora-source' with the current yumdownloader,
it will auto enable the source repos for all enabled repos.
Comment 2 Ian Collier 2007-07-13 13:38:28 EDT
I find that yumdownloader cannot download anything at all as a non-root user. 
Is this the same bug, and if so when can we expect yum-utils 1.1.6 to appear in
Fedora updates?

$ yumdownloader yum-utils
Loading "installonlyn" plugin
Cannot access repository dir /var/tmp/yum-setup-fbpUna/fedora

[/var/tmp/yum-setup-fbpUna turns out to exist but is empty]

Thanks
Comment 3 Tim Lauridsen 2007-07-13 13:46:25 EDT
I will push a new release sometime next week.
Comment 4 Fedora Update System 2007-07-27 01:50:40 EDT
yum-utils-1.1.6-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-08-13 13:05:02 EDT
yum-utils-1.1.6-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.