Bug 242287 - Traceback on SELinux Management on non-english desktop environment
Summary: Traceback on SELinux Management on non-english desktop environment
Status: CLOSED DUPLICATE of bug 242269
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 00:32 UTC by Luya Tshimbalanga
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 17:37:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luya Tshimbalanga 2007-06-03 00:32:20 UTC
Description of problem:
SELinux Management caused a traceback.

Version-Release number of selected component (if applicable):


How reproducible:
Users on non-english desktop tries to open SELinux management

Steps to Reproduce:
1.Set Language in non-english
2.Access SELinux Management or using terminal system-config-selinux
3.
  
Actual results:
Traceback below

$ system-config-selinux 
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 32, in
<module>
    import statusPage
  File "/usr/share/system-config-selinux/statusPage.py", line 58, in <module>
    gettext.install(PROGNAME, localedir="/usr/share/locale", unicode=1)
  File "/usr/lib64/python2.5/gettext.py", line 493, in install
    t = translation(domain, localedir, fallback=True, codeset=codeset)
  File "/usr/lib64/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib64/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.5/gettext.py", line 314, in _parse
    plural = v[1].split('plural=')[1]
IndexError: list index out of range


Expected results:
Panel should appear.

Additional info:

Comment 1 Daniel Walsh 2007-06-04 17:37:35 UTC

*** This bug has been marked as a duplicate of 242269 ***


Note You need to log in before you can comment on or make changes to this bug.