Bug 24229 - XFree86-libs-4.0.2-1 breaks KDE!
XFree86-libs-4.0.2-1 breaks KDE!
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: kcontrol (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 13:39 EST by Sammy
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-11 13:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-01-17 13:39:44 EST
This is very unusual since I have a desktop system where this is not
happening.

It is happening on my DELL Inspiron 4000 notebook, Basically KDE/KDM
all hang and there are some messages on console which come from the
DCOP server not being able to connect with anonymous-xxxx.... I go back
to XFree86-libs-4.0.2-0.2 and everything works fine. Everyhing else is
at 4.0.2-1 level (rawhide Jan 12). I did reinstall my KDE and Mesa and
glibc, tried older versions etc and the libs is the only thing that
does it.

Sorry that I cannot be more detailed.
Comment 1 Sammy 2001-01-18 15:43:51 EST
OK...some more info (I think 24231 bug is same!)...the reason this did not
happen on my desktop was because I was using the NVIDIA driver instead of 
the nv driver that comes with XFree86-4.0.2-1! When I switch to nv same error
happens here too with same remedy...go back to -0.2 version of -libs- only.
I am using everything from rawhide (Jan 17) except KDE 2.0.1 rpms from earlier
rawhide release. Everything was working fine with -0.2 release!

Here is the error:

DCOP aborting call from 'anonymous-1086' to 'kicker'
ERROR: KUniqueApplication: DCOP communication error!
DCOP aborting call from 'anonymous-1088' to 'klipper'
ERROR: KUniqueApplication: DCOP communication error!
DCOP aborting call from 'anonymous-1090' to 'khotkeys'
ERROR: KUniqueApplication: DCOP communication error!
DCOP aborting call from 'anonymous-1092' to 'kwrited'
ERROR: KUniqueApplication: DCOP communication error!
DCOP aborting call from 'anonymous-1095' to 'knotify'
ERROR: KUniqueApplication: DCOP communication error!


Comment 2 Bernhard Rosenkraenzer 2001-01-18 17:36:32 EST
I'm writing this from Konqueror, running on a KDE desktop and XFree86 
4.0.2-1, without using any proprietary drivers (on a Matrox G400, though).

You mention you're using ancient KDE packages that were compiled 
against a prior version of XFree86 - please try either use the current KDE 
(yes, it is safe to use despite the fact that it's from CVS) or to recompile 
the KDE packages you're using, and let us know if this changes anything.

Comment 3 Kristian 2001-01-30 05:56:23 EST
Similar incompatibility happens here as well. After installing 4.0.2-1 there are
no available charsets to select in KDE control center and everything is
displayed with the iso10646-1. Goes for both KDE snapshot 01/22/01 in Rawhide
and 2.1b2. After going back to 4.0.2-0.2 everything seems to be normal. For the
ref, I have a G400 card but I don't think it is an issue here..
Comment 4 Mike A. Harris 2001-02-11 13:21:39 EST
Reassigning to KDE package..  Looks like a kde issue.
Comment 5 Bernhard Rosenkraenzer 2001-02-28 12:44:59 EST
We can't reproduce this on any of our machines.
Try using the current versions.
+

Note You need to log in before you can comment on or make changes to this bug.