Bug 242316 - Firefox crashes when fonts are missing
Summary: Firefox crashes when fonts are missing
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 08:29 UTC by Krzysio (Chris) Leszczynski
Modified: 2018-04-11 17:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 11:49:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The result of strace running firefox (102.97 KB, application/x-bzip)
2007-06-03 08:29 UTC, Krzysio (Chris) Leszczynski
no flags Details

Description Krzysio (Chris) Leszczynski 2007-06-03 08:29:39 UTC
Description of problem:
Firefox crashes within a second when pointed to http://pl.wikipedia.org/
I'm not sure whether this is a bug in firefox or in pango. 

Version-Release number of selected component (if applicable):
latest yummed today:
firefox-2.0.0.4-1.fc7
pango-1.16.4-1.fc7

How reproducible:
always

Steps to Reproduce:
1. firefox http://pl.wikipedia.org/

  
Actual results:
Crashes immediately, other pages (google, slashdot, en.wikipedia.org) work
correctly.

Expected results:
  :-)

Additional info:
It worked perfectly just before I upgraded from FC6 to F7 yesterday.
I'm not sure whether this is problem with firefox or with pango.
The firefox output the following to stderr:
(gecko:13045): Pango-WARNING **: shape engine failure, expect ugly output. the
offending font is 'Lucida Sans Not-Rotated 8.4990234375'

I'm attaching the result of strace. I was unable to make ltrace.

Comment 1 Krzysio (Chris) Leszczynski 2007-06-03 08:29:39 UTC
Created attachment 156018 [details]
The result of strace running firefox

Comment 2 Matěj Cepl 2007-06-04 11:18:26 UTC
Not able to reproduce this on FC7. Tried to use Lucida Sans Unicode fonts (which
is presumably what you have) and even browse through many different wikipedias
(even those, which are not possible to display with Lucida Sans font) and
firefox didn't crash.

Comment 3 Krzysio (Chris) Leszczynski 2007-06-04 22:48:13 UTC
I found that after upgrading from FC6 to FC7 my Java Development Kit was
uninstalled. I found that Firefox tries to open the font from Java toolkit and
then crashes immediately.
      futex(0xa340508, FUTEX_WAKE, 1)         = 1
      open("/usr/share/fonts/java/LucidaSansRegular.ttf", O_RDONLY) = -1 ENOENT
(No such file or directory)
      --- SIGSEGV (Segmentation fault) @ 0 (0) ---
      unlink("/home/chris/.mozilla/firefox/0vio21ts.default/lock") = 0
      rt_sigaction(SIGSEGV, {SIG_DFL}, NULL, 8) = 0

I just added the missing font and voila! Firefox runs on every page sweetly.
Still I think it should make SIGSEGV just because one of its truetype is
missing. Again, I'm not sure whether this is inside firefox or pango library.


Comment 4 Behdad Esfahbod 2007-06-05 02:28:51 UTC
can you somehow get a backtrace of who's opening that font file?
I'm pretty sure I've hardened Pango to survive missing fonts.

Comment 5 Martin Stransky 2007-09-11 12:29:51 UTC
Taking that bug.

Comment 6 Martin Stransky 2007-10-16 11:49:08 UTC
Unable to reproduce. Closing as WORKSFORME. Please reopen if you find a reliable
way how to reproduce it.


Note You need to log in before you can comment on or make changes to this bug.