Bug 24232 - problems with ypserv + rmmod
problems with ypserv + rmmod
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-17 14:15 EST by Gerald Teschl
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 08:46:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-01-17 14:15:13 EST
I don't quite understand this, but here is the problem:
Server and all clients run rh7.0 + all updates.

From time to time ypserve starts spanning children until it reaches its
limit.
The load will go up to 30 and the sever will not react for about a minute.
After that everything is fine again.

Inspecting the log shows that this happens always after rmmod is executed
by
cron:

Jan 16 11:30:01 keen CROND[26630]: (root) CMD (   /sbin/rmmod -as)
Jan 16 11:31:01 keen ypserv[626]: WARNING(ypproc_all_2_svc): too many
running children

A "ps" shows:

  626 ?        D      2:04 ypserv
  642 ?        S      0:00 [ypbind]
  646 ?        S      0:03 [ypbind]
  647 ?        S      0:00 [ypbind]
  651 ?        S      0:02 [ypbind]
<snip>
28643 ?        D      0:00 ypserv
.
.
.
28678 ?        D      0:00 ypserv

It does not happen every time rrmod is executed. In addition, it is not
related
to server activity, since it will also happen in the night when nobody uses
the
system. I have removed the kmod entry form cron.d and it hasn't occured
since.
Comment 1 Florian La Roche 2001-02-13 08:51:52 EST
I don't see how this "rmmod" can directly be a problem for ypserv. Are you
running in
some limit for the number of processes on this machine?

If you still have logfiles pointing at the real problem we run into here, please
reopen
a new bug-report with more information. It might be that ypserv should have
further
checks for error returns, but I need more information on what exactly is going
wrong.

Thaks for this report.
Comment 2 Gerald Teschl 2001-03-23 08:46:07 EST
Resolved by the 2.2.17-14 kernel.

Note You need to log in before you can comment on or make changes to this bug.