Bug 242320 - during init, contents of /etc/udev/devices cannot be copied to /dev
Summary: during init, contents of /etc/udev/devices cannot be copied to /dev
Status: CLOSED DUPLICATE of bug 241712
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-03 09:52 UTC by Kahlil Hodgson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 15:49:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kahlil Hodgson 2007-06-03 09:52:05 UTC
Description of problem:
Contents of /etc/udev/devices/ cannot be copied to /dev/ at startup (permission
denied).

Version-Release number of selected component (if applicable):
Everything is up-2-date.

How reproducible:
Put anything in /etc/udev/devices.

Steps to Reproduce:
1. Place copies of the nivida (lol) devices ( nvidia{0-3,ctl} ) under
/etc/udev/devices/
2. Reboot

Actual results:
Permission denied errors.  Devices are not copied
  
Expected results:
Devices copied. No Errors

Additional info:
Okay, one of the livna packages initially produced this error.  An update to the
package puts the appropriate stuff in /etc/udev/makedev.d/ makes the nvidia card
usable, but I had to manually remove the files under /etc/udev/devices to
silence the error messages.  

Now if I run /sbin/start_udev after startup it works, but during startup it
barfs.  Perhaps perms on /dev during startup?  Wish I had a spare machine to
test this on :-)  Getting a bit tired of rebooting my box.

Comment 1 Harald Hoyer 2007-06-04 09:49:20 UTC
/etc/udev/devices/ is deprecated and does not work with selinux anyway. 

Comment 2 Kahlil Hodgson 2007-06-04 11:02:35 UTC
Okay, cool.  I did try with and without selinux to no avail.  Yer seems 
problematic the more I think about it.  Interesting reading about udev 
anyway :-)  I'll send a note to the livna -- perhaps they can do a 
cleanup in the next update.

Comment 3 Harald Hoyer 2007-06-04 15:49:00 UTC

*** This bug has been marked as a duplicate of 241712 ***


Note You need to log in before you can comment on or make changes to this bug.