Bug 242322 - Install F7 from external USB drive is impossible
Install F7 from external USB drive is impossible
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 06:10 EDT by Joachim Backes
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 01:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2007-06-03 06:10:23 EDT
Description of problem:

if i try to install F7 from an external USB DVD drive, it will not install, but
offers a prompt where I can select to install from local CDROM, HD, NFS a.s.o.,
and i miss the usual prompt for verifying the install media.

If then i select "local cdrom", then my internal IDE-drive is eject, but if i
then insert the F7 DVD, it is not accepted.

On the other hand, booting directly from an internal IDE DVD drive goes fine and
will install.

Version-Release number of selected component (if applicable):
F7 install media

How reproducible:
Each time

Steps to Reproduce:
1.Boot the F7 install DVD from an external USB drive
2.
3.
  
Actual results:
the install process will not be offered

Expected results:
install will proceed

Additional info:
Comment 1 Gabor Kovacs 2007-07-27 12:18:49 EDT
It's the same on arch x86_64. Looking for installation media, anaconda offers
/dev/scd among local hard drives but fails to continue. Installing from an USB
DVD drive would be great for rack mounted servers without DVD drive.
Comment 2 David Cantrell 2007-08-22 17:15:38 EDT
The installation scenario should work, but we need to see log messages on tty2
and tty3.  Since you are early in the boot process (stage 1), you'll need to use
a digital camera and take pictures of the screen on tty2 and then on tty3. 
Attach the images to this bug report.
Comment 3 Gabor Kovacs 2007-08-22 20:21:42 EDT
Since then I have some details. If the computer have NOT got any IDE CD/DVD
drive, only the USB external drive, selecting the "Local CDROM" as source will
offer a list of drivers, where I can choose usb-storage and then everything
works fine. But if there is an old IDE CD drive (which can't read my F7 DVD) the
installer automatically selects it and I can't choose any driver or the USB
drive. As I see this was the situation in backes' case, too. I think there
should be a way to force to load usb-storage driver even if an already detected
IDE CD-ROM exists.
Comment 4 David Cantrell 2007-08-23 10:53:33 EDT
Have you tried booting with the 'askmethod' boot option?  That forces anaconda
to ask you what install source to use.  We have a number of boot time options
for anaconda:

http://fedoraproject.org/wiki/AnacondaOptions
Comment 5 Gabor Kovacs 2007-08-23 11:55:41 EDT
Though 'askmethod' doesn't help (It actually asks method without it but
selecting 'Local CDROM' only ejects my old IDE CDROM), 'nostorage' is a
workaround. With this option I can load 'usb-storage' as the first driver and
then the USB DVD device will be recognized as 'Local Cdrom' source. Of course in
this case other HDD drivers should be load manually, too. So this bug may be
transformed to a wish that 'Local Cdrom' may assume/probe more than one cdrom
drive with different drivers automatically. Thanks for the help.
Comment 6 Joachim Backes 2007-08-28 02:36:13 EDT
Hi,

it is really impossible to get the tty loggings, because: If booting from the
DVD, then for a very short time a text based screen appears, which is
overwritten by a graphical screen where I can select the installer boot mode,
and here, no tty is available!
Comment 7 David Cantrell 2007-08-28 10:34:48 EDT
Once the graphical portion of the installer loads, it's just running X.  You can
switch to tty2 or tty3 just as if you would on a regular system:  press
Ctrl+Alt+F2 or Ctrl+Alt+F3.
Comment 8 Joachim Backes 2007-08-29 01:29:26 EDT
Seems to be a misunderstanding: it is not possible to catch the
F7-installer-boot-screen (in text mode): immediately after isolinux starts from
the DVD, the usual bootwindow (as in earlier FC installs) appears for some
milliseconds, disappears, and then  a multicolored boot window appears where I
can select the boot mode (text, graphical, rescue a.s.o). So I cannot switch to
any console in this state.
Comment 9 David Cantrell 2007-08-29 10:35:45 EDT
Forget the screen you're thinking about.  You want to _boot_ anaconda and let it
start the installer.  In both the stage 1 part of the installer (the part that
asks you where the installation source is) and the stage 2 part (the graphical
installer interface), you can switch to other virtual consoles and check log output.

Let it boot in to stage 1.  I am assuming you are able to get that load, but it
won't progress to stage 2 (hence not being able to find the CD drive).  While in
stage 1, press Alt+F3 and look at the log messages.  Check Alt+F4 as well. 
We're looking for device info on these screens.

What would be even more useful is to leave your CD-ROM drive attached, but tell
it to install from HTTP.  This will let it proceed to stage 2 (the graphical
installer) and at that point you can go over to the shell on tty2 (Ctrl+Alt+F2)
and copy the log files from /tmp and attach them to this bug report.  They
contain device detection information which will be helpful.

Bug reporting for anaconda is a bit irritating, I know, so we wrote up this page
to help explain how to get the information we're looking for:

http://fedoraproject.org/wiki/AnacondaBugReporting

I know you aren't seeing a crash, but the information on this page is also
helpful to just get to the point of collecting log information, which is what we
really need.
Comment 10 Joachim Backes 2007-08-30 05:13:40 EDT
Sorry, but

1. Stage 1 runs
2. If I leave the DVD attached and I tell to install from HTTP, then
   no graphical X installer is started, but immediately the prompt for 
   the network connect is presented (IP4/IP6, IP Address aso).
3. So no shell is started, and I cannot copy the log files from /tmp
   to some other places.
4. In stage 1, all messages look normal.
Comment 11 David Cantrell 2008-04-22 21:20:59 EDT
Is this happening with the Fedora 9 preview release?

http://fedoraproject.org/en/get-prerelease
Comment 12 Joachim Backes 2008-04-23 01:00:52 EDT
No, it's not happening under F9 prerel: The install proceeds as expected.

Note You need to log in before you can comment on or make changes to this bug.