Bug 242333 - Dell XPS M1210 fails to resume
Dell XPS M1210 fails to resume
Status: CLOSED DUPLICATE of bug 240082
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2007-06-03 08:51 EDT by Jonathan Underwood
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-04 18:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2007-06-03 08:51:18 EDT
Description of problem:
Suspend (to ram) on a Dell XPS M1210 stopped working with F7. It worked fine
with FC6 with all kernels. The machine suspends without hitch, but on trying to
resume it either completely hangs with no screens on and no activity, or reboots

Let me know if there's anything else I can do to debug.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jonathan Underwood 2007-06-03 08:57:51 EDT
Have tried the following quirks to no avail:
Comment 2 Jonathan Underwood 2007-06-03 09:08:44 EDT
I tried to follow the debugging instructions as described here:


but, oddly, the file /sys/power/pm_trace does not exist:

# ls /sys/power/
disk  image_size  resume  state

What gives?
Comment 3 Jonathan Underwood 2007-06-03 09:13:10 EDT
Hm. This seems to be because CONFIG_PM_TRACE and CONFIG_PM_DEBUG are not set for
the current F7 kernel build. Wouldn't it be a grand idea to turn these back on
again so users can debug suspend/resume problems without having to rebuild kernel?
Comment 4 Jonathan Underwood 2007-06-04 17:51:47 EDT
Aha! Culprit found.

This is caused by the kvm and kvm_intel kernel modules.

Having the following in /etc/pm/config.d/unload_modules does the trick, allowing
the machine to resume:

SUSPEND_MODULES="iwl3945 mac80211 kvm_intel kvm"

removing kvm_intel and kvm from that list renders the system unable to resume.
Comment 5 Jonathan Underwood 2007-06-04 17:55:12 EDT
Damn bugzilla, can't reassign the bug to kvm, as it's officially in Extras.
Closing bug here and opening a new one.

Did I mention that I hate the Fedora/RH bugzilla?
Comment 6 Jonathan Underwood 2007-06-04 18:00:40 EDT
I wonder if the kvm patches mentioned here for the kernel are any help:

Comment 7 Jonathan Underwood 2007-06-04 18:08:25 EDT
Sorry, managed to make a mess of reassigning this bug.
Comment 8 Jonathan Underwood 2007-06-04 18:10:15 EDT

*** This bug has been marked as a duplicate of 240082 ***

Note You need to log in before you can comment on or make changes to this bug.