Bug 242334 - FC6->F7 upgrade w/ mdadm.conf created new mdadm.conf w/o all devices listed
FC6->F7 upgrade w/ mdadm.conf created new mdadm.conf w/o all devices listed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
: 246081 383641 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 08:52 EDT by Matt Domsch
Modified: 2008-05-07 09:58 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 08:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2007-06-03 08:52:22 EDT
Description of problem:

System has 3 /dev/md[012] devices specified.  I upgraded my home system from FC6
x86_64 to Fedora 7.  Upgrade went swimmingly, but after rebooting, failed to
find /dev/md1.  Turns out, the mdadm.conf created by anaconda during upgrade
only listed one of the three devices.

# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md0 level=raid1 num-devices=2 uuid=78ba6d85:41879a19:2824ae70:ef3682fd


Instead, it should have found and listed all three, as I had before:
# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md1 level=raid1 num-devices=2 uuid=7a25ecec:a5faab44:893f6233:da3bc07e
ARRAY /dev/md2 level=raid1 num-devices=2 uuid=04676aa7:b1621d52:a169be0f:6160572c
ARRAY /dev/md0 level=raid1 num-devices=2 uuid=78ba6d85:41879a19:2824ae70:ef3682fd

fixing this and remaking the initrd, I was able to boot successfully.

Version-Release number of selected component (if applicable):
Fedora 7 gold

How reproducible:
unknown
Comment 1 Vadym Chepkov 2007-06-10 13:56:53 EDT
The same happened to me twice and it doesn't matter if I used upgrade mode or
yum. I ended up with non-bootable system.
Comment 2 Orion Poplawski 2007-06-12 15:52:32 EDT
Me too.  Let me know if you need any logs.
Comment 3 Paul Howarth 2007-06-18 10:21:31 EDT
Me too. I have LVM-on-RAID1 and in an FC-6 to F-7 upgrade, my /etc/mdadm.conf
was replaced with one containing only:

# mdadm.conf written out by anaconda
DEVICE partitions
MAILADDR root
ARRAY /dev/md0 level=raid1 num-devices=2 UUID=a6023eda:5dd9ef69:a77f13f3:6e25e139

Booting the DVD in rescure mode, I used "mdadm --detail --scan" to recover the
missing information and create a new /etc/mdadm.conf:

# mdadm.conf written out by anaconda and edited by Paul
DEVICE partitions
MAILADDR root
ARRAY /dev/md0 level=raid1 num-devices=2 UUID=a6023eda:5dd9ef69:a77f13f3:6e25e139
ARRAY /dev/md1 level=raid1 num-devices=2 uuid=451ff0fc:fb610ea3:d05d0076:442ef352
ARRAY /dev/md2 level=raid1 num-devices=2 UUID=9ea76464:ea298b64:4dd98395:c2064a2b
ARRAY /dev/md3 level=raid1 num-devices=2 UUID=78e55309:7dba3918:1f3e29d4:75f5d52e
ARRAY /dev/md4 level=raid1 num-devices=2 UUID=fb599c79:d8f72cc9:0fb29f9f:d716c262
ARRAY /dev/md5 level=raid1 num-devices=2 UUID=29034664:e2924612:bc076052:789a4a40

After re-making the initrd I was then able to boot.

I have another machine with multiple RAID1 devices that I did a fresh install of
F7 on, and there was no problem with that.
Comment 4 edwinh 2007-06-28 09:21:34 EDT
bah.  This happened to me too, and I didn't find this entry from searching until
after I submitted my own bugzilla.   I can't see how to mark it a duplicate
myself, but is the same as #246081.

Comment 5 Paul Howarth 2007-06-28 09:26:58 EDT
*** Bug 246081 has been marked as a duplicate of this bug. ***
Comment 6 Matt Domsch 2007-09-21 22:35:09 EDT
pjones, is this likely to have been fixed in anaconda for F8?
Comment 7 Jeremy Katz 2007-10-29 14:30:36 EDT
I don't see how it wouldn't be -- we now unconditionally do our fsset writeout
which also includes writing an mdadm.conf.  The only way I could see it not
happening is if we don't detect all of the raid arrays on upgrade
Comment 8 Phil Anderson 2007-12-19 08:35:49 EST
This still exists in FC8 when upgrading from FC7.  See bug 383641 (which is
probably a duplicate of this).
Comment 9 Olle Liljenzin 2008-02-05 02:28:59 EST
Also when upgrading FC6->F8. The backup made before the upgrade confirms 
mdadm.conf had both md0 and md1, but only md0 afterwards.

On comment 7: The root file system was on md1, including the 
updated /etc/mdadm.conf, so I don't think the volume wasn't detected.
Comment 10 Joel Andres Granados 2008-04-24 08:33:52 EDT
This should all be better for f9.  We use mdadm to write configuration now. 
Please reopen if you see the same behavior.
Comment 11 Joel Andres Granados 2008-05-07 09:58:49 EDT
*** Bug 383641 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.