Bug 242340 - After upgrade to F7 from FC6 , sun.misc.InvalidJarIndexException: Invalid index
After upgrade to F7 from FC6 , sun.misc.InvalidJarIndexException: Invalid index
Status: CLOSED DUPLICATE of bug 241245
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Vivek Lakshmanan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 09:50 EDT by Cristian Oancea
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 11:47:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Oancea 2007-06-03 09:50:27 EDT
Description of problem:

Tomcat 5 Servcer doesn't start anymore.


Version-Release number of selected component (if applicable):
tomcat5 5.5.23

How reproducible:
install tomcat5 and dependends rpms, try to start the service tomcat5 as root.
service tomcat5 start
in the log file "catalina.out" you'll get 


Steps to Reproduce:
1. install tomcat5 rpms
2. start the tomcat5 service 
3. check the contexts , and the log file 
4. call into web browser localhost:8080 
  
Actual results:
any context is activated 

Expected results:
contexts to be activated and to be shown upon request.

Additional info:
sun.misc.InvalidJarIndexException: Invalid index


at org.apache.commons.modeler.Registry.findDescriptor (Registry.java:960)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:665)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:1014)
at org.apache.commons.modeler.Registry.registerCompon ent(Registry.java:831)
at org.apache.catalina.connector.Connector.start(Conn ector.java:1077)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:457)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:433)
02-Jun-2007 21:23:22 org.apache.catalina.connector.Connector start
SEVERE: Protocol JMX registration failed
sun.misc.InvalidJarIndexException: Invalid index
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:854)
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:762)
at sun.misc.URLClassPath$JarLoader.findResource(URLCl assPath.java:732)
at sun.misc.URLClassPath.findResource(URLClassPath.ja va:145)
at java.net.URLClassLoader$2.run(URLClassLoader.java: 362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findResource(URLClassLoade r.java:359)
at java.lang.ClassLoader.getResource(ClassLoader.java :977)
at java.lang.ClassLoader.getResource(ClassLoader.java :972)
at org.apache.commons.modeler.Registry.loadDescriptor s(Registry.java:867)
at org.apache.commons.modeler.Registry.findDescriptor (Registry.java:960)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:665)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:1014)
at org.apache.commons.modeler.Registry.registerCompon ent(Registry.java:831)
at org.apache.catalina.connector.Connector.start(Conn ector.java:1077)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:457)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:433)
02-Jun-2007 21:23:22 org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
02-Jun-2007 21:23:23 org.apache.commons.modeler.Registry registerComponent
SEVERE: Error registering Catalina:type=ProtocolHandler,port=8009
sun.misc.InvalidJarIndexException: Invalid index
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:854)
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:762)
at sun.misc.URLClassPath$JarLoader.findResource(URLCl assPath.java:732)
at sun.misc.URLClassPath.findResource(URLClassPath.ja va:145)
at java.net.URLClassLoader$2.run(URLClassLoader.java: 362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findResource(URLClassLoade r.java:359)
at java.lang.ClassLoader.getResource(ClassLoader.java :977)
at java.lang.ClassLoader.getResource(ClassLoader.java :972)
at org.apache.commons.modeler.Registry.loadDescriptor s(Registry.java:867)
at org.apache.commons.modeler.Registry.findDescriptor (Registry.java:960)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:665)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:1014)
at org.apache.commons.modeler.Registry.registerCompon ent(Registry.java:831)
at org.apache.catalina.connector.Connector.start(Conn ector.java:1077)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:457)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:433)
02-Jun-2007 21:23:23 org.apache.catalina.connector.Connector start
SEVERE: Protocol JMX registration failed
sun.misc.InvalidJarIndexException: Invalid index
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:854)
at sun.misc.URLClassPath$JarLoader.getResource(URLCla ssPath.java:762)
at sun.misc.URLClassPath$JarLoader.findResource(URLCl assPath.java:732)
at sun.misc.URLClassPath.findResource(URLClassPath.ja va:145)
at java.net.URLClassLoader$2.run(URLClassLoader.java: 362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findResource(URLClassLoade r.java:359)
at java.lang.ClassLoader.getResource(ClassLoader.java :977)
at java.lang.ClassLoader.getResource(ClassLoader.java :972)
at org.apache.commons.modeler.Registry.loadDescriptor s(Registry.java:867)
at org.apache.commons.modeler.Registry.findDescriptor (Registry.java:960)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:665)
at org.apache.commons.modeler.Registry.findManagedBea n(Registry.java:1014)
at org.apache.commons.modeler.Registry.registerCompon ent(Registry.java:831)
at org.apache.catalina.connector.Connector.start(Conn ector.java:1077)
at org.apache.catalina.core.StandardService.start(Sta ndardService.java:457)
at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
at org.apache.catalina.startup.Catalina.start(Catalin a.java:552)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:295)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:433)
02-Jun-2007 21:23:23 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
02-Jun-2007 21:23:23 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/27 config=null
02-Jun-2007 21:23:23 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
02-Jun-2007 21:23:23 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1170 ms
Comment 1 Vivek Lakshmanan 2007-06-04 11:47:51 EDT

*** This bug has been marked as a duplicate of 241245 ***
Comment 2 Rubens Gomes 2007-06-06 12:47:03 EDT
I am still having problems.  Here is further info:

[root@localhost tomcat5]# yum list installed 'tomcat*'
Loading "installonlyn" plugin
Installed Packages
tomcat5.i386                             5.5.23-0jpp.1.0.3.el5  installed
tomcat5-admin-webapps.i386               5.5.23-0jpp.1.0.3.el5  installed
tomcat5-common-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
tomcat5-jasper.i386                      5.5.23-0jpp.1.0.3.el5  installed
tomcat5-jsp-2.0-api.i386                 5.5.23-0jpp.1.0.3.el5  installed
tomcat5-server-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
tomcat5-servlet-2.4-api.i386             5.5.23-0jpp.1.0.3.el5  installed
tomcat5-webapps.i386                     5.5.23-0jpp.1.0.3.el5  installed


[root@localhost init.d]# /etc/init.d/tomcat5 version Server version: Apache
Tomcat/5.5.20
Server built:   May 14 2007 05:33:51
Server number:  5.5.20.0
OS Name:        Linux
OS Version:     2.6.18-8.1.4.el5
Architecture:   i386
JVM Version:    1.5.0_12-b04
JVM Vendor:     Sun Microsystems Inc.
[root@localhost init.d]#


portion of catalina.out:
Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:       
Jun 6, 2007 9:23:28 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path:
/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/lib/i386/client:/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/lib/i386:/usr/lib/jvm/java-1.5.0-sun-1.5.0.12/jre/../lib/i386
Jun 6, 2007 9:23:28 AM org.apache.commons.modeler.Registry registerComponent
SEVERE: Error registering Catalina:type=StringCache
sun.misc.InvalidJarIndexException: Invalid index
	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:769)
	at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:682)
	at sun.misc.URLClassPath$JarLoader.findResource(URLClassPath.java:663)
	at sun.misc.URLClassPath.findResource(URLClassPath.java:142)
	at java.net.URLClassLoader$2.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findResource(URLClassLoader.java:359)
	at java.lang.ClassLoader.getResource(ClassLoader.java:977)
	at org.apache.commons.modeler.Registry.loadDescriptors(Registry.java:895)
	at org.apache.commons.modeler.Registry.findDescriptor(Registry.java:992)
	at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:696)
	at org.apache.commons.modeler.Registry.findManagedBean(Registry.java:1047)
	at org.apache.commons.modeler.Registry.registerComponent(Registry.java:859)
	at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:775)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:504)
	at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:267)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:432)
Jun 6, 2007 9:23:28 AM org.apache.catalina.core.StandardServer initialize
SEVERE: Error registering 
Comment 3 Vivek Lakshmanan 2007-06-06 14:07:31 EDT
(In reply to comment #2)
> I am still having problems.  Here is further info:
> 
> [root@localhost tomcat5]# yum list installed 'tomcat*'
> Loading "installonlyn" plugin
> Installed Packages
> tomcat5.i386                             5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-admin-webapps.i386               5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-common-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-jasper.i386                      5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-jsp-2.0-api.i386                 5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-server-lib.i386                  5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-servlet-2.4-api.i386             5.5.23-0jpp.1.0.3.el5  installed
> tomcat5-webapps.i386                     5.5.23-0jpp.1.0.3.el5  installed
> 
> 
This is a bug about FC-6 -> F-7 and you seem to be running RHEL-5. If you are
seeing this on RHEL-5 then please open a bug against tomcat5 in RHEL-5. For the
record I am not able to reproduce this issue in RHEL-5. Please make sure you
have jakarta-commons-modeler-1.1-8jpp.1.0.2.el5 as well. Again, please post
responses to this in a bug against tomcat5 in RHEL-5...

Note You need to log in before you can comment on or make changes to this bug.