Bug 242391 - Black screen on boot up
Black screen on boot up
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 242200 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 19:24 EDT by David
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.21-1.3228.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 13:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (17.11 KB, text/plain)
2007-06-03 19:24 EDT, David
no flags Details
dmesg log (17.40 KB, application/octet-stream)
2007-06-07 18:35 EDT, David
no flags Details

  None (edit)
Description David 2007-06-03 19:24:26 EDT
Description of problem:
On bootup, right when xwindows starts the screen goes black and thats it.  I can
ssh in remotely, so the server is working, just xwindows is not.

Using opensource Radeon driver.  It worked perfectly on FC6 and on F7 I did a
grpahical install, so you know the xwindows works!

However on my first boot after install / upgrade it went black.  I checked
/etc/X11/xorg.conf its all perfect.

If I ssh in remotely as root and try to startx...

[root@four etc]# startx
xauth:  creating new authority file /root/.serverauth.2899


X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux four.engineering.idb 2.6.21-1.3194.fc7 #1 SMP
Wed May 23 22:35:01 EDT 2007 i686
Build Date: 11 May 2007
Build ID: xorg-x11-server 1.3.0.0-5.fc7
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  4 09:20:38 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) No devices detected.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
[root@four etc]#


I have attached /var/log/Xorg.0.log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David 2007-06-03 19:24:27 EDT
Created attachment 156043 [details]
Xorg.0.log
Comment 2 David 2007-06-03 19:37:12 EDT
I even tried starting f7 with 3 in grub

Then ssh in and Xorg -configure...

[root@four X11]# Xorg -configure

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Fedora Core 7 Red Hat, Inc.
Current Operating System: Linux four.engineering.idb 2.6.21-1.3194.fc7 #1 SMP
Wed May 23 22:35:01 EDT 2007 i686
Build Date: 11 May 2007
Build ID: xorg-x11-server 1.3.0.0-5.fc7
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  4 09:35:42 2007
List of video drivers:
        v4l
        voodoo
        chips
        intel
        tdfx
        ztv
        vmware
        neomagic
        apm
        sis
        via
        amd
        cyrix
        siliconmotion
        dummy
        r128
        trident
        tseng
        i128
        ark
        mga
        ati
        savage
        radeon
        i810
        cirrus
        sisusb
        i740
        nouveau
        nv
        s3
        s3virge
        glint
        ast
        nsc
        atimisc
        rendition
        fbdev
        vesa
        vga
(EE) LoadModule: Module ztv does not have a ztvModuleData data object.
(EE) Failed to load module "ztv" (invalid module, 0)
No devices to configure.  Configuration failed.
Comment 3 Matěj Cepl 2007-06-04 18:47:28 EDT
possibly dupe with bug 242026 ?
Comment 4 David 2007-06-05 05:44:28 EDT
Hmmm similar - only that that bug is for nvidia, mine is an ATI Radeon (but
using the open source standard drivers.  I filed this bug as I am not using a
nvidia and its related but different.  Means its something common regardless of
if your running radeon, nvidia, or anything quite possibly.
Comment 5 David 2007-06-05 19:16:05 EDT
I want to add to this yesterday I booted the server and xwindows worked, but
only ONCE.  I got the graphical screen after the first two checks (in text mode
at the start).  I could logon, use it, log off, and back on.

I then shutdown and rebooted and black screen again.

I think its not detecting the PCI card.  The machine on the installer cd did
complain about this bug..

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242200

However again one time I got the quirk messages, but it continued.  I managed
the upgrade from FC6 to F7 floorlessly in graphical update mode.

But I would honestly say, out of maybe 30 to 40 starts, the graphics have worked
 on two occasions.

I really think this bug is related to the PCI quirk error on the installer and
clearly xwindows does not 'see' the card.

But I have proven yesterday that when it does it works just perfectly.

Thanks
Comment 6 David 2007-06-06 05:15:12 EDT
Here is a dump of lspci -v, its not detecting the video card!

[root@four ~]# lspci -v
00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge
(rev 03)
        Subsystem: Tyan Computer Unknown device 1a30
        Flags: bus master, fast devsel, latency 0
        Memory at 44000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge
(rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66MHz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 0000c000-0000cfff
        Memory behind bridge: e4000000-e5ffffff
        Prefetchable memory behind bridge: d0000000-dfffffff

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 12) (prog-if 00
[Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        I/O behind bridge: 0000a000-0000bfff
        Memory behind bridge: e6000000-e7ffffff
        Prefetchable memory behind bridge: 40000000-400fffff

00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 12)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 Controller (rev 12)
(prog-if 80 [Master])
        Subsystem: Intel Corporation Unknown device 2442
        Flags: bus master, medium devsel, latency 0
        [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
        [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
        [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
        I/O ports at f000 [size=16]

00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
(prog-if 00 [UHCI])
        Subsystem: Intel Corporation 82801BA/BAM USB Controller #1
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at d000 [size=32]

00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus Controller (rev 12)
        Subsystem: Intel Corporation Unknown device 2442
        Flags: medium devsel, IRQ 11
        I/O ports at 0500 [size=16]

00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB Controller #1 (rev 12)
(prog-if 00 [UHCI])
        Subsystem: Intel Corporation Unknown device 2442
        Flags: bus master, medium devsel, latency 0, IRQ 5
        I/O ports at d800 [size=32]

02:04.0 RAID bus controller: Silicon Image, Inc. PCI0680 Ultra ATA-133 Host
Controller (rev 02)
        Subsystem: Silicon Image, Inc. Winic W-680 (Silicon Image 680 based)
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at a000 [size=8]
        I/O ports at a400 [size=4]
        I/O ports at a800 [size=8]
        I/O ports at ac00 [size=4]
        I/O ports at b000 [size=16]
        Memory at e7000000 (32-bit, non-prefetchable) [size=256]
        [virtual] Expansion ROM at 40000000 [disabled] [size=512K]
        Capabilities: [60] Power Management version 2

02:09.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
        Subsystem: Ensoniq Creative Sound Blaster AudioPCI128
        Flags: bus master, slow devsel, latency 32, IRQ 11
        I/O ports at b400 [size=64]
        Capabilities: [dc] Power Management version 1

02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit
Ethernet (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 5
        I/O ports at b800 [size=256]
        Memory at e7001000 (32-bit, non-prefetchable) [size=256]
        [virtual] Expansion ROM at 40080000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2

[root@four ~]#
Comment 7 Adam Jackson 2007-06-06 17:49:06 EDT
Wow, impressive.

Can you attach dmesg output as well?  The kernel is clearly getting PCI setup
very very wrong.
Comment 8 David 2007-06-07 18:32:34 EDT
No Problems its attached after this.
Comment 9 David 2007-06-07 18:35:32 EDT
Created attachment 156522 [details]
dmesg log

Here is dmesg log dump as requested.

I do believe its the kernel as I did mention, the installer bug I had with the
machine, but as I said out of maybe 30 starts it will run once properly.

This is the installer bug..

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242200
Comment 10 David 2007-06-11 19:52:13 EDT
Any update on this?  Is it the kernel, as maybe this bug needs to be changed to
kernel.
Comment 11 Matěj Cepl 2007-06-11 20:39:26 EDT
Sorry overlooked this and hasn't reassigned yet.
Comment 12 David 2007-06-13 05:31:12 EDT
I tried this and proved 100% its the kernel at fault.

downloaded the latest fc6 kernel

http://redhat.download.fedoraproject.org/pub/fedora/linux/core/updates/6/i386/kernel-2.6.20-1.2952.fc6.i686.rpm

rpm -ivh --oldpackage kernel-2.6.20-1.2952.fc6.i686.rpm

rebooted into that kernel

ABSOLUTELY floorless (apart from sdx to hdx in fstab).  I boot up and xwindows
runs just perfectly.

Can you get this bug moved over to kernel please?  Also I have no doubt that my
installer bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242200 is
also a kernel issue.

Thanks!
Comment 13 Adam Jackson 2007-06-14 12:13:40 EDT
Over to kernel.
Comment 14 Chuck Ebbert 2007-06-14 12:28:58 EDT
*** Bug 242200 has been marked as a duplicate of this bug. ***
Comment 15 Chuck Ebbert 2007-06-14 12:31:03 EDT
From dmesg:
PCI quirk region 0400-047F claimed by ICH4 ACPI GPIO TCO
PCI quirk region 0400-04BF claimed by ICH4 GPIO

Something very strange has happened with PCI setup.
David, please post dmesg from the FC6 kernel.
Comment 16 David 2007-06-14 20:18:35 EDT
Hi Chuck,
Just to let you know I updated the kernel to the latest F7 build today. While I was very short of time, I did reboot and the machine came up normal on the new kernel. I will confirm this later, but does the new kernel have changes that could have fixed this bug? Its encouraging as maybe out of 20 starts it would start okay once.
So odds are it is fixed by this kernel, but I need more starts to be sure.
Cheers David
Comment 17 David 2007-06-15 03:50:57 EDT
Hi Chuck,
Further follow up.  I have started and stopped the machine 4 times and not once
did I get the error, so the issue IS fixed.

However can you confirm what was changed in the kernel and can it be noted, else
this fault can slip back into future kernels or fedora versions.

Thanks!
David
Comment 18 David 2007-06-20 19:46:52 EDT
Any news or update, is it fixed and won't re-appear?
Comment 19 Chuck Ebbert 2007-06-21 13:37:16 EDT
Fix was probably in 2.6.21.5, can't tell offhand which one it was.
Closing as fixed.
Comment 20 David 2007-07-11 19:15:36 EDT
Hey Chuck,

I just updated this machine with Kernel 2.6.21-1.3255.fc7 from updates-testing
and the damn bug is back!  Its the same issue as before as it goes to identify
all the PCI cards.

Seems in the last kernel it was only fixed as a fluke as I had worried about.

Can the maintainers see what they did in 2.6.21-1.3228.fc7 to fix the issue
concerning detection of the PCI cards and do a new kernel.

This kernel 2.6.21-1.3255.fc7 should not leave testing as it has reintroduced
the bug.

Can this bug be re opened please.

Let me know what you need from the machine with the buggy 2.6.21-1.3255.fc7 kernel.

Cheers,

David

Note You need to log in before you can comment on or make changes to this bug.