Bug 242401 - Anaconda attempts to use excessively large swap partition on 32-bit system, and fails
Anaconda attempts to use excessively large swap partition on 32-bit system, a...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 22:13 EDT by dedded
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 22:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda's dump file (82.41 KB, text/plain)
2007-06-03 22:13 EDT, dedded
no flags Details

  None (edit)
Description dedded 2007-06-03 22:13:12 EDT
Description of problem:

Note, the summary is a guess on my part.  Here's what happened:

1. Begin clean F7 install.  System has a very large swap partition (9GB).
   (Swap partition never used, but exists.)
   System is a 32-bit i686 (P4, Dell 4600).
2. Anaconda fails after disk partitioning info entered.  I selected custom
   partitioning, and selected a partition for Anaconda to format as ext3 
   and mount as /.
3. Anaconda let's me save a trace to floppy (attached).
4. I re-format the overly large swap partition as an ext3 filesystem, and
   then re-attempt the install, which now proceeds without problems.

My conjecture is that the problem is that Anaconda is trying to use a swap
partition that is too large for a 32-bit system.

Version-Release number of selected component (if applicable):

Version on the Fedora 7 install DVD.  (Am on FC6 at the moment, and can't find
an F7 package list.)

How reproducible:  

Have only tried once, but guess that you can reproduce by creating a 9GB swap
partition and then trying to install F7.

Actual results:

Install fails.

Expected results:

Anaconda does not attempt to use such a large swap partition on a 32-bit
machine.

Additional info:

See attached.
Comment 1 dedded 2007-06-03 22:13:13 EDT
Created attachment 156046 [details]
Anaconda's dump file
Comment 2 Chris Lumens 2007-06-04 10:58:37 EDT
Judging by the following messages in your exception information, it looks like
you may have bad media.  Did you check your DVD using mediacheck prior to
installation?

<6>sr0: Current: sense key: Medium Error
<6>    Additional sense: No seek complete
<4>end_request: I/O error, dev sr0, sector 5516128
<3>Buffer I/O error on device sr0, logical block 1379032
<3>SQUASHFS error: sb_bread failed reading block 0xb75b
<3>SQUASHFS error: Unable to read page, block 2dd115d, size 5d76
<3>SQUASHFS error: sb_bread failed reading block 0xb75b
<3>SQUASHFS error: Unable to read page, block 2dd115d, size 5d76
<3>SQUASHFS error: sb_bread failed reading block 0xb75b
<3>SQUASHFS error: Unable to read page, block 2dd115d, size 5d76
<3>SQUASHFS error: sb_bread failed reading block 0xb75b
<3>SQUASHFS error: Unable to read page, block 2dd115d, size 5d76
Comment 3 dedded 2007-06-04 21:33:10 EDT
I checked the media's MD5 sum (piped dd into md5sum), which matched that of the
.iso.  So I thought the media to be okay.  But I did not run the media check
after booting from that DVD.

However, the install went fine from the same DVD in the same drive on my second
attempt, after re-formatting the swap partition.
Comment 4 dedded 2007-06-04 22:10:50 EDT
Just converted the partition back to a large swap partition and re-attempted the
Fedora 7 install (from the same DVD).  No problems this time.  Sorry for the
false alarm.  (Now back to re-customizing the F7 install...)

Note You need to log in before you can comment on or make changes to this bug.