Bug 24246 - can't run up2date - undefined symbol: fdio
Summary: can't run up2date - undefined symbol: fdio
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-17 22:49 UTC by Don Beusee
Modified: 2015-01-07 23:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 18:23:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Don Beusee 2001-01-17 22:49:25 UTC
I just tried for the first time to run up2date, and I got:

# up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio
#

What's causing this error?  All the packages I have installed are updated
to the latest.

Comment 1 Preston Brown 2001-02-09 03:56:40 UTC
I have no idea.

please show us:

rpm -qa|grep rpm
rpm -qa|grep up2date
rpm -V rpm up2date up2date-gnome

Comment 2 Don Beusee 2001-02-09 04:27:31 UTC
# rpm -qa|grep rpm
rpm-4.0-4
rpmlint-0.14-4
rpmdb-redhat-7.0-0.20000830
rpm-build-4.0-4
rpmfind-1.5-3
rpm-python-4.0-4
gnorpm-0.95.1-5
rpm2html-1.4-4
# rpm -qa|grep up2date
up2date-2.1.7-1
up2date-gnome-2.1.7-1
# rpm -V rpm up2date up2date-gnome
# 


Comment 3 Cristian Gafton 2001-02-20 01:34:56 UTC
Assigned QA to jturner

Comment 4 Preston Brown 2001-02-20 18:09:10 UTC
jeff, seems to be an rpm issue.  What is he missing that rpmlib is requiring?

Comment 5 Jeff Johnson 2001-02-20 18:23:41 UTC
The symbol is a vector used for I/O within rpm, the complaint when invoking
up2date
indicates an up2date/rpm package mismatch.

Dunno the versions of up2date are well enough to tell you exactly what's wrong,
but
you're gonna need to find out what up2date package goes with the rpm-4.0 package
shipped in Red Hat 7.0.

Comment 6 Jeff Johnson 2001-02-21 18:14:43 UTC
Fixed (by adding dependency to rpm-python) in CVS, will be in rpm-4.0.2-7x.
final


Note You need to log in before you can comment on or make changes to this bug.