Bug 242464 - GDM and automounted NFS home directories
GDM and automounted NFS home directories
Status: CLOSED DUPLICATE of bug 242230
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 09:22 EDT by Andrew Clayton
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 06:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Clayton 2007-06-04 09:22:16 EDT
Description of problem:

Users home directories are automounted over NFS. Prior to Fedora 7 this caused
no problems with GDM. However I am now running into the following issue.

At initial startup no user directories are mounted. /home is empty.Upon entering
the username/password I am presented with the following dialogue:

"Your home directory is listed as '/home/andrew' but it does not appear to
exist. Do you want to log in with the / (root) directory as your home
directory?. It is unlikely anything will work unless you use failsafe
session."

Click No and try again, login succeeds.


If you logout and your home directory gets unmounted it looks like this:

dr-xr-xr-x 2 root root 0 2007-06-04 13:36 andrew

Upon trying to log back in we get the following message:

"User's $HOME/.dmrc file is being ignored. This prevents the default session
and language from being saved. File should be owned by user and have 644
permissions. User's $HOME directory must be owned by user and not writable by
others.

Clicking OK, gets us logged in.

We have:

$ ls -l .dmrc
-rw-r--r-- 1 andrew andrew 24 2006-10-23 15:29 .dmrc

$ ls -l ../
total 12
drwx-----x 116 andrew andrew 8192 2007-06-04 13:48 andrew


Version-Release number of selected component (if applicable):

gdm-2.18.0-14.fc7.x86_64


How reproducible:

100%


This is with x86_64 Fedora 7 with all current updates applied. Used the 
Fedora 7 supplied kernel and my previous 2.6.22-rc3
Comment 1 Marcin 2007-06-04 09:38:34 EDT
The same effect with F7 i386 with or w/o updates. Initial login with default  F7
gdm theme fails. Subsequent ones succeeds. Changing the GDM theme to old ones
has no effect.
Comment 2 Marcin 2007-06-06 06:23:32 EDT
Seems to be a autofs bug 242230. Resolved in updates-testing
Comment 3 Andrew Clayton 2007-06-06 06:44:37 EDT
Heh, I was just trying out the new gdm and autofs from updates-testing and found
that the autofs update fixed it.

Cheers,


*** This bug has been marked as a duplicate of 242230 ***

Note You need to log in before you can comment on or make changes to this bug.