Bug 242535 - ppc64 build
Summary: ppc64 build
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: atlas   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Quentin Spencer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 18:26 UTC by Orion Poplawski
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 21:28:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2007-06-04 18:26:21 UTC
Description of problem:

Current altas spec doesn't build for ppc64.  This breaks a number of downstream
packages (specifically numpy and its dependencies).  Support might be as simple as:

cvs diff: Diffing .
Index: atlas.spec
===================================================================
RCS file: /cvs/pkgs/rpms/atlas/devel/atlas.spec,v
retrieving revision 1.7
diff -u -r1.7 atlas.spec
--- atlas.spec  8 Sep 2006 14:31:43 -0000       1.7
+++ atlas.spec  4 Jun 2007 18:24:35 -0000
@@ -110,7 +110,7 @@


 %endif
-%ifarch ppc
+%ifarch ppc ppc64
 %define archt powerpc
 %define types base altivec

If you'd like, I'd be happy to commit this and submit a test build.

Comment 1 Quentin Spencer 2007-06-04 18:37:25 UTC
Go ahead.

By the way, wouldn't it be preferred to link numpy et al. be to lapack & blas so
that atlas is optional rather than mandatory?


Comment 2 Orion Poplawski 2007-06-04 21:28:12 UTC
Indeed, it looks like numpy in CVS has dropped the atlas-devel requirement, but
it just hasn't been built.  I've filed a bug to ping the maintainer.

I've checked in an built the changes (3.6.0-12) and it compiled fine on ppc64. 
Hopefully it actually works.


Note You need to log in before you can comment on or make changes to this bug.