Bug 242563 - update to 1.0.3, need ppc64 build
Summary: update to 1.0.3, need ppc64 build
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: numpy   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-04 20:14 UTC by Orion Poplawski
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 1.0.3-0.1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 13:26:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2007-06-04 20:14:15 UTC
Description of problem:

My devel build of python-matplotlib failed on F8 (and probably with on F7 as
well) due to no ppc64 package for numpy.  This should be able to be fixed by
simply building what's in CVS at the moment (1.0.2-2) but appears to never have
been built. 

Also, 1.0.3 has been released.  Here's an initial patch:

diff -u -r1.17 numpy.spec
--- numpy.spec  14 May 2007 18:29:44 -0000      1.17
+++ numpy.spec  4 Jun 2007 20:12:58 -0000
@@ -3,16 +3,16 @@
 %{!?python_version: %define python_version %(%{__python} -c 'import sys; print
sys.version.split(" ")[0]' || echo "2.3")}

 Name:           numpy
-Version:        1.0.2
-Release:        2%{?dist}
+Version:        1.0.3
+Release:        1%{?dist}
 Summary:        A fast multidimensional array facility for Python

 Group:          Development/Languages
 License:        BSD
 URL:            http://numeric.scipy.org/
-Source0:        http://dl.sourceforge.net/numpy/%{name}-%{version}.tar.gz
+Source0:        http://dl.sourceforge.net/numpy/%{name}-%{version}-2.tar.gz
 Patch0:         numpy-1.0.1-f2py.patch
-Patch1:         numpy-1.0-gfortran.patch
+Patch1:         numpy-1.0.3-site.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

 BuildRequires:  python-devel blas-devel lapack-devel python-setuptools gcc-gfortran
@@ -33,9 +33,9 @@
 this package is a version of f2py that works properly with NumPy.

 %prep
-%setup -q
+%setup -q -n %{name}-%{version}
 %patch0 -p1 -b .f2py
-%patch1 -p1 -b .gfortran
+%patch1 -p1 -b .site

 %build
 env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
@@ -74,6 +74,9 @@
 %{python_sitearch}/%{name}

 %changelog
+* Mon Jun  4 2007 Orion Poplawski 1.0.3-1
+- Update to 1.0.3
+
 * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
 - Drop BR: atlas-devel, since it just provides binary-compat
   blas and lapack libs. Atlas can still be optionally used

[orion@cynosure devel]$ cat numpy-1.0.3-site.patch
--- numpy-1.0.3/setup.py.site   2007-05-30 22:11:05.000000000 -0600
+++ numpy-1.0.3/setup.py        2007-06-04 13:58:10.000000000 -0600
@@ -49,8 +49,8 @@
     config.add_subpackage('numpy')

     config.add_data_files(('numpy','*.txt'))
-    config.add_data_files(('.','COMPATIBILITY'),('.','scipy_compatibility'),
-                           ('.','site.cfg.example'))
+   
config.add_data_files(('numpy','COMPATIBILITY'),('numpy','scipy_compatibility'),
+                           ('numpy','site.cfg.example'))

     config.get_version('numpy/version.py') # sets config.version

Comment 1 Jarod Wilson 2007-06-06 13:54:09 UTC
Ugh. What the heck are they doing with a tarball named like that... Regardless,
I'll try to get this pushed through today.

Comment 2 Jarod Wilson 2007-06-06 18:48:40 UTC
Builds for devel, f7 and fc6 completed successfully.

Comment 3 Fedora Update System 2007-06-06 22:01:18 UTC
numpy-1.0.3-0.1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Andreas Madsack 2007-06-11 09:34:41 UTC
After updating to numpy 1.0.3-0.1.fc6 this problem occurs using scipy:

/usr/lib64/python2.4/site-packages/scipy/misc/__init__.py:25:
DeprecationWarning: ScipyTest is now called NumpyTest; please update your code
  test = ScipyTest().test
/usr/lib64/python2.4/site-packages/scipy/fftpack/__init__.py:21:
DeprecationWarning: ScipyTest is now called NumpyTest; please update your code
  test = ScipyTest().test

Is there a new scipy-version which fixes this issue?

System: AMD X2-64bit / Fedora Core 6 / all updates until yesterday


Comment 5 Andreas Madsack 2007-06-11 09:35:32 UTC
additional info: 
scipy-version: 0.5.2-1.1.fc6

Comment 6 Jarod Wilson 2007-06-11 14:52:20 UTC
Its just a warning, which is likely to be fixed in a forthcoming version of
scipy, but 0.5.2 is currently still the latest released version so far as I can
tell. Perhaps file a new bug against scipy to keep track of the issue.

Comment 7 Fedora Update System 2007-06-16 13:26:07 UTC
numpy-1.0.3-0.1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.