Bug 242567 - libnotify/notification-daemon cyclic build dep
libnotify/notification-daemon cyclic build dep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 16:27 EDT by Bastien Nocera
Modified: 2013-03-05 22:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 05:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-06-04 16:27:19 EDT
After updating libwnck to another soname:
http://koji.fedoraproject.org/koji/getfile?taskID=26103&name=root.log

You can't rebuild notification-daemon, because it requires libnotify-devel,
which requires libnotify which requires notification-daemon.

ie. to rebuild notification-daemon, you need notification-daemon.
Comment 1 Matthias Clasen 2007-06-04 16:31:14 EDT
You need to bootstrap by temporarily building a libnotify without the daemon
requirement, I'd say
Comment 2 Bastien Nocera 2007-06-04 17:55:10 EDT
I asked for the soname to be downgraded again:
http://bugzilla.gnome.org/show_bug.cgi?id=444119

Hopefully that'll get fixed before I get to this problem.
Comment 3 Bastien Nocera 2007-06-05 05:59:02 EDT
Matthias fixed it, closing.

Note You need to log in before you can comment on or make changes to this bug.