Bug 242601 - BUG: warning at kernel/softirq.c:138/local_bh_enable()
BUG: warning at kernel/softirq.c:138/local_bh_enable()
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 243610 243678 243749 243781 244548 251860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-04 20:28 EDT by Paul Sipot
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.6.21-1.3228.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 11:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Sipot 2007-06-04 20:28:24 EDT
Description of problem:
Crash. Happens on both PCs that have Fedora7 installed. I can't seem to find the
reason to this.

Version-Release number of selected component (if applicable):
# 2.6.21-1.3194.fc7

How reproducible:
Happens seemingly at random, when I restarted mysqld, used dmesg, at boot.

Actual results:
###################################################
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb
 =======================
--------------------------------------------------
Jun  4 23:22:18 laptop kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
Jun  4 23:22:18 laptop kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  4 23:22:18 laptop kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  4 23:22:18 laptop kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  4 23:22:18 laptop kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  4 23:22:18 laptop kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  4 23:22:18 laptop kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  4 23:22:18 laptop kernel:  [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
Jun  4 23:22:18 laptop kernel:  [<c0459850>] file_read_actor+0x0/0xe0
Jun  4 23:22:18 laptop kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  4 23:22:18 laptop kernel:  [<c0475b33>] do_readv_writev+0xbc/0x187
Jun  4 23:22:18 laptop kernel:  [<c059863b>] sock_aio_write+0x0/0x102
Jun  4 23:22:18 laptop kernel:  [<c043cfe9>] tick_program_event+0x3a/0x59
Jun  4 23:22:18 laptop kernel:  [<c0439e57>] hrtimer_interrupt+0x18d/0x1b6
Jun  4 23:22:18 laptop kernel:  [<c043d245>] tick_sched_timer+0x0/0xbb
Jun  4 23:22:18 laptop kernel:  [<c0475c3b>] vfs_writev+0x3d/0x48
Jun  4 23:22:18 laptop kernel:  [<c04760a4>] sys_writev+0x41/0x95
Jun  4 23:22:18 laptop kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  4 23:22:18 laptop hidd[2107]: Bluetooth HID daemon
Jun  4 23:22:18 laptop kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
Jun  4 23:22:18 laptop kernel:  =======================
--------------------------------------------------
Jun  3 08:40:26 laptop kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
Jun  3 08:40:26 laptop kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  3 08:40:26 laptop kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  3 08:40:26 laptop kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  3 08:40:26 laptop kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  3 08:40:26 laptop kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  3 08:40:26 laptop kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  3 08:40:26 laptop rpc.statd[1949]: statd running as root. chown
/var/lib/nfs/statd/sm to choose different user
Jun  3 08:40:26 laptop kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
Jun  3 08:40:27 laptop kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  3 08:40:27 laptop kernel:  [<c0475d47>] vfs_write+0xbc/0x154
Jun  3 08:40:27 laptop kernel:  [<c0476342>] sys_write+0x41/0x67
Jun  3 08:40:27 laptop kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  3 08:40:27 laptop kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
Jun  3 08:40:27 laptop kernel:  =======================
--------------------------------------------------
Jun  3 09:40:23 laptop kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
Jun  3 09:40:23 laptop kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  3 09:40:23 laptop kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  3 09:40:23 laptop kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  3 09:40:23 laptop kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  3 09:40:23 laptop kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  3 09:40:23 laptop kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  3 09:40:23 laptop kernel:  [<c04753ea>] do_sync_readv_writev+0xc1/0xfe
Jun  3 09:40:23 laptop kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  3 09:40:23 laptop kernel:  [<c0475b33>] do_readv_writev+0xbc/0x187
Jun  3 09:40:23 laptop kernel:  [<c059863b>] sock_aio_write+0x0/0x102
Jun  3 09:40:23 laptop kernel:  [<c0475c3b>] vfs_writev+0x3d/0x48
Jun  3 09:40:23 laptop kernel:  [<c04760a4>] sys_writev+0x41/0x95
Jun  3 09:40:23 laptop kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  3 09:40:23 laptop kernel:  =======================
--------------------------------------------------
Jun  3 11:33:40 laptop kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Tainted: P      )
Jun  3 11:33:40 laptop rpc.statd[1949]: Version 1.0.11 Starting
Jun  3 11:33:40 laptop kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  3 11:33:40 laptop kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  3 11:33:40 laptop kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  3 11:33:40 laptop rpc.statd[1949]: statd running as root. chown
/var/lib/nfs/statd/sm to choose different user
Jun  3 11:33:40 laptop kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  3 11:33:40 laptop kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  3 11:33:40 laptop kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  3 11:33:40 laptop kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
Jun  3 11:33:40 laptop kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  3 11:33:40 laptop kernel:  [<c0475d47>] vfs_write+0xbc/0x154
Jun  3 11:33:40 laptop kernel:  [<c0476342>] sys_write+0x41/0x67
Jun  3 11:33:40 laptop kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  3 11:33:40 laptop kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
Jun  3 11:33:40 laptop kernel:  =======================
Comment 1 pobbz 2007-06-05 06:44:43 EDT
I saw the same message in console during the install (from network) of F7.
However, it didn't seem to have any effect on the installation process. 

Actually, now that I checked, the same message seems to be present in my dmesg
too and I've been running F7 for a couple of days now w/o any problems. However,
my kernel doesn't seem to be "tainted":

BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c05dec95>] inet_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0xb

Doesn't seem serious to me as it doesn't seem to have any effect on anything.
Comment 2 Dave Jones 2007-06-05 17:15:05 EDT
fixed in CVS.
Comment 3 Julien Dumont 2007-06-10 20:00:54 EDT
This occurs also for me when using iwl3945 wireless driver.
The driver crash but the connection stay still open for the system but unusabe.

Distribution: Fedora core 7

Hardware Environment:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T7400  @ 2.16GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4325.45
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T7400  @ 2.16GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 4096 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 4321.89
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:


00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G71 [Quadro FX 2500M] (rev a1)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822
SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 0a)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit
Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)


Software Environment:
openvpn

Problem Description:

Wifi driver for Intel 3945 pro wireless card crash. Connection still open but
unusable.

Steps to reproduce:

load the wifi driver iwl3945 with mac80211 and rc80211_simple

dmesg output :

wlan0: duplicate address detected!
iwl3945: REPLY_ADD_STA failed
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
tun0: Disabled Privacy Extensions
BUG: warning at kernel/softirq.c:138/local_bh_enable() (Not tainted)

Call Trace:
 [<ffffffff80229e7b>] local_bh_enable+0x42/0x98
 [<ffffffff8025c008>] cond_resched_softirq+0x35/0x4b
 [<ffffffff8022e9f5>] release_sock+0x59/0xaa
 [<ffffffff8021c0a4>] tcp_recvmsg+0x9ca/0xadf
 [<ffffffff803e9352>] sock_alloc_send_skb+0x77/0x1d2
 [<ffffffff8022f84e>] sock_common_recvmsg+0x30/0x45
 [<ffffffff8022e1fc>] sock_recvmsg+0xf8/0x117
 [<ffffffff80296d97>] get_futex_key+0x47/0x10c
 [<ffffffff80293107>] autoremove_wake_function+0x0/0x2e
 [<ffffffff8029725f>] futex_wake+0xc6/0xd5
 [<ffffffff8023b31e>] do_futex+0x25f/0xc1e
 [<ffffffff802167c3>] do_sync_write+0xc9/0x10c
 [<ffffffff80229db4>] sys_recvfrom+0xe2/0x130
 [<ffffffff8043cc00>] unix_ioctl+0xc5/0xce
 [<ffffffff8025711e>] system_call+0x7e/0x83

wlan0: No ProbeResp from current AP xx:xx:xx:xx:xx:xx - assume out of range
wlan0: No STA entry for own AP xx:xx:xx:xx:xx:xx

uname -a output :
2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:47:07 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
 
Comment 4 Dave Jones 2007-06-11 00:59:24 EDT
*** Bug 243610 has been marked as a duplicate of this bug. ***
Comment 5 Chuck Ebbert 2007-06-11 11:17:14 EDT
*** Bug 243678 has been marked as a duplicate of this bug. ***
Comment 6 Chuck Ebbert 2007-06-11 14:06:14 EDT
*** Bug 243749 has been marked as a duplicate of this bug. ***
Comment 7 Chuck Ebbert 2007-06-11 17:28:45 EDT
*** Bug 243781 has been marked as a duplicate of this bug. ***
Comment 8 Neal Becker 2007-06-11 17:59:55 EDT
fyi, no iwl3945 here, but do have bcm4318.
Comment 9 Ignacio Vazquez-Abrams 2007-06-17 09:58:02 EDT
*** Bug 244548 has been marked as a duplicate of this bug. ***
Comment 10 Chuck Ebbert 2007-08-13 11:38:05 EDT
*** Bug 251860 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.