Bug 242609 - yum.conf variable expansion problem.
Summary: yum.conf variable expansion problem.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-05 02:35 UTC by Charles Curley
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 06:28:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles Curley 2007-06-05 02:35:29 UTC
Description of problem:

yum.conf variable expansion problem.

Version-Release number of selected component (if applicable):

3.1.6


How reproducible:

Always

Steps to Reproduce:

1. Create a local repo with a path component where the variable is not the
entire name of the directory, e.g.
baseurl=ftp://reposerver/pub/f$releasever/F-7-i386-DVD.iso (as opposed to
...pub/7/F....

2. Edit the file fedora-core.repo to use the said repo.

3. Try to use yum.

  
Actual results:

[root@taltos ~]# yum list emacs*
Loading "installonlyn" plugin


Cannot open/read repomd.xml file for repository: core
[root@taltos ~]#


Expected results:

[root@taltos ~]# yum list emacs*
Loading "installonlyn" plugin
primary.xml.gz            100% |=========================| 619 kB    00:00     
core      : ################################################## 1628/1628
primary.xml.gz            100% |=========================|  186 B    00:00     
Available Packages
emacs.i386                               22.0.990-2.fc7         core            
emacs-common.i386                        22.0.990-2.fc7         core            
[root@taltos ~]

Additional info:

Expanding the variable manually works, e.g.:

baseurl=ftp://reposerver/pub/f7/F-7-i386-DVD.iso

Comment 1 Seth Vidal 2007-06-05 04:31:41 UTC
could you send the output of:

rpm -q fedora-release


thanks!


Comment 2 Charles Curley 2007-06-05 04:52:21 UTC
[root@taltos ~]# cat /etc/fedora-release 
Fedora release 6.93 (Rawhide)

Sorry, I didn't realize I had installed from the wrong ISO until just now (it
should be f7). I will reinstall in the morning & see if the problem is still there.

Comment 3 Seth Vidal 2007-06-05 06:28:20 UTC
I think you'll find this isn't a bug. B/c you had 6.93 $releasever doesn't
become 7, it only becomes 6.93

hence, the problem.



Note You need to log in before you can comment on or make changes to this bug.