Bug 242619 - Banshee Crashes in Fedora 7
Banshee Crashes in Fedora 7
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 00:59 EDT by Jack Deslippe
Modified: 2007-12-27 18:31 EST (History)
0 users

See Also:
Fixed In Version: fc7-updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 18:31:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Deslippe 2007-06-05 00:59:46 EDT
Description of problem:

Banshee crashes whenever I attempt to a play a song on my desktop.  My laptop
plays fine.  

Version-Release number of selected component (if applicable):
banshee-0.12.1-2.fc7

How reproducible:
Start Banshee and attempt to play a song.
  
Actual results:

Banshee crashes with the following error:
ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstaudioresample.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

Additionally the following output when Banshee first loads is different on my
desktop (which crashes) and my laptop (which works).  

** (Banshee:17989): WARNING **: Add decoder bethsoftvid (107) please

** (Banshee:17989): WARNING **: Add decoder c93 (106) please

** (Banshee:17989): WARNING **: Add decoder dnxhd (103) please

** (Banshee:17989): WARNING **: Add decoder dsicinvideo (97) please

** (Banshee:17989): WARNING **: Add decoder dxa (102) please

** (Banshee:17989): WARNING **: Add decoder gif (100) please

** (Banshee:17989): WARNING **: Add decoder kmvc (88) please

** (Banshee:17989): WARNING **: Add decoder nuv (87) please

** (Banshee:17989): WARNING **: Add decoder ptx (108) please

** (Banshee:17989): WARNING **: Add decoder sgi (105) please

** (Banshee:17989): WARNING **: Add decoder smackvid (86) please

** (Banshee:17989): WARNING **: Add decoder targa (96) please

** (Banshee:17989): WARNING **: Add decoder thp (104) please

** (Banshee:17989): WARNING **: Add decoder tiertexseqvideo (98) please

** (Banshee:17989): WARNING **: Add decoder tiff (99) please

** (Banshee:17989): WARNING **: Add decoder VMware video (92) please

** (Banshee:17989): WARNING **: Add decoder atrac 3 (86050) please

** (Banshee:17989): WARNING **: Add decoder dsicinaudio (86045) please

** (Banshee:17989): WARNING **: Add decoder imc (86046) please

** (Banshee:17989): WARNING **: Add decoder gsm (86037) please

** (Banshee:17989): WARNING **: Add decoder gsm_ms (86049) please

** (Banshee:17989): WARNING **: Add decoder mpc sv7 (86047) please

** (Banshee:17989): WARNING **: Add decoder smackaud (86042) please

** (Banshee:17989): WARNING **: Add decoder wavpack (86044) please


Expected results:
It not to crash!

Additional info:
Others have reported having the same bug here: 
http://forums.fedoraforum.org/showthread.php?t=156708
Comment 1 Jack Deslippe 2007-06-05 01:11:00 EDT
I thought I would also mention that googling the bug brought up this page:
http://banshee-project.org/forums/viewtopic.php?t=3  - I am not sure if our bug
is caused by the same thing, however.
Comment 2 Christopher Aillon 2007-06-05 01:44:02 EDT
Yep, bug in liboil.  I already built this, but it's waiting for the updates
people to sign and push it to the repo.  In the meantime, you can get the new
liboil packages from http://www.gnome.org/~caillon/temp/
Comment 3 Jack Deslippe 2007-06-06 02:11:15 EDT
Thanks for the quick answer.  I'll look for the update!
Comment 4 Fabian M. Schindler 2007-06-09 12:29:52 EDT
Perhaps it is related to this, perhaps not (I am not sure), but banshee also
crashes when you try to burn an audio-CD from ogg-files. Should I submit a new
bug or is this perhaps caused by the same liboil bug?
Comment 5 Christopher Aillon 2007-12-27 18:31:09 EST
Whoops, sorry for the lack of response.  I didn't realize there was something I
still needed to do here.  I'd say file a new bug if you haven't yet.  Going to
mark this closed since the liboil fix hit the updates server a bit ago.

Note You need to log in before you can comment on or make changes to this bug.