Bug 242624 - RHN Taskomatic not sending 2way prop email for some customers.
RHN Taskomatic not sending 2way prop email for some customers.
Status: CLOSED WORKSFORME
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
RHN Stable
All Linux
high Severity high
: ---
: ---
Assigned To: rhn-dev-list
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 02:02 EDT by Bala Govindan
Modified: 2016-05-22 19:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-08 07:12:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bala Govindan 2007-06-05 02:02:14 EDT
Description of problem: (this issue is logged by GIT - Bala Govindan)
2way prop process creates a record in web_customer_notification table and
taskomatic picks this record and sends an email to the customer. The issue is
that there has been customer complaints that they do not get this email
sometimes. I thought it was random, but now I could replicate it. For the
following customer the email never goes out

select * from web.web_customer
where oracle_customer_number = '901532'

I believe the issue could be around the fact that there are too many emails (too
many org admins) and so it could be failing. That's my guess...but please
research this and fix this asap as it is not only affecting this customer...it
is affecting many more customers.

Thanks
Bala Govindan.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Oracle CRM/ERP insert a record to web_customer_notification
2. RHN taskomatic picks and send the email
3. It fails for some customers (eg: oracle_customer_number = '901532')
  
Actual results:
Email not sent.

Expected results:
Email go out...

Additional info:
The last email I got for this particular account was on 20-Mar-2007. So
something broke this after that or may be there were more org admins added to
this account after that.
Comment 1 Kevin A. Smith 2007-06-05 08:35:16 EDT
Not sure that this is a taskomatic issue. I _thought_ that Java webapp was
responsible for triggering the email. Transferring to the hosted team for follow up.
Comment 3 Sebastian Skracic 2011-11-08 07:12:59 EST
2way prop no more in RHN.

Note You need to log in before you can comment on or make changes to this bug.