Bug 242640 - rpmbuild incorrecly reports config/build errors
rpmbuild incorrecly reports config/build errors
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 05:07 EDT by redtux
Modified: 2008-01-25 12:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 12:28:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redtux 2007-06-05 05:07:57 EDT
when I run rpmbuild -bb specfile and the configure script fails for any reason 
(changed options etc) the build fails silently.

rpmbuild -bc gives results I would expect - ie: tells me the error

This is very confusing
Comment 1 Jeff Johnson 2007-06-06 00:54:04 EDT
Do you have a reproducer for the problem?

I agree very confusing.
Comment 2 Jeff Johnson 2007-06-20 23:13:57 EDT
Without a reproducer, it is impossible to fix rpmbuild behavior.

NEEDINFO
Comment 3 Panu Matilainen 2007-08-10 09:10:46 EDT
A reproducer please...
Comment 4 Panu Matilainen 2008-01-25 12:28:59 EST
Closing due to inactivity...

Note You need to log in before you can comment on or make changes to this bug.