Bug 242646 - thunderbird 2.0.0.0-1.fc7 quits automatically
thunderbird 2.0.0.0-1.fc7 quits automatically
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-05 05:31 EDT by Ming Jiang
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-05 12:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ming Jiang 2007-06-05 05:31:46 EDT
Description of problem:
I have two accounts set up in my thunderbird, one IMAP and the other Gmail POP.
While the IMAP one works fine, whenever I tried to open a message in Gmail inbox
the program quites automatically without leaving any errors in the logs. 


Version-Release number of selected component (if applicable):
2.0.0.0-1.fc7


How reproducible:
Always


Steps to Reproduce:
1. Setup 2 accounts in thunderbird, one imap and one pop(preferrably gmail)
2. Send one mail to your gmail account
3. Open the new mail in gmail inbox
  
Actual results:
thunderbird automatically quits

Expected results:
the mail should have been opened without any errors

Additional info:
Never had this problem in thunderbird 1.5 in FC6.
Comment 1 Matěj Cepl 2007-06-05 09:15:14 EDT
Try something like this, in gnome-terminal (or whichever terminal emulator you
use) write these commands:

export NSPR_LOG_FILE=/tmp/thunderbird-debug-log.txt
export NSPR_LOG_MODULES=POP3:5
thunderbird

try to download your emails from gmail and quit thunderbird. Then attach please
/tmp/thunderbird-debug-log.txt as an attachment to this bug.
Comment 2 Ming Jiang 2007-06-05 10:19:34 EDT
(In reply to comment #1)
> Try something like this, in gnome-terminal (or whichever terminal emulator you
> use) write these commands:
> 
> export NSPR_LOG_FILE=/tmp/thunderbird-debug-log.txt
> export NSPR_LOG_MODULES=POP3:5
> thunderbird
> 
> try to download your emails from gmail and quit thunderbird. Then attach please
> /tmp/thunderbird-debug-log.txt as an attachment to this bug.

I tried your suggestion, but the log file wasn't created after thunderbird quits. 
Comment 3 Matěj Cepl 2007-06-05 11:39:41 EDT
Are you sure that you have configuration for GMail POP correct (e.g., I
struggled for a moment with the fact, that GMail works only over SSL)? Otherwise
I cannot reproduce this problem, so I am getting suspect, that the problem is in
your configuration.
Comment 4 Ming Jiang 2007-06-05 12:14:14 EDT
I found the problem. 

If I tried to setup the Gmail account with the built-in Gmail settings of
Thunderbird 2 despite that all the parameters(SSL, TLS, port numbers, etc.) are
correct, it will cause problem. 

After I have recreated my gmail account manually, it's working now. 

Note You need to log in before you can comment on or make changes to this bug.