Bug 242776 - Architecture `sparc-sun4us-solaris' is not supported
Architecture `sparc-sun4us-solaris' is not supported
Status: CLOSED DUPLICATE of bug 206998
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
unspecified
sparc Other
low Severity high
: ---
: ---
Assigned To: Clifford Perry
Red Hat Satellite QA List
:
Depends On:
Blocks: 172657
  Show dependency treegraph
 
Reported: 2007-06-05 14:58 EDT by Carl Speare
Modified: 2010-01-11 11:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-11 11:30:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Speare 2007-06-05 14:58:58 EDT
Description of problem:
RHN Satellite does not properly support Fujitsu-based (sun4us) SPARC64-V
processors. (Examples include the entire series of Fujitsu PrimePower servers.)

Version-Release number of selected component (if applicable):
RHN Satellite 4.2.0

How reproducible:
Always.

Steps to Reproduce:
1. rhnreg_ks --serverUrl=http://<redacted>/XMLRPC --activationkey=<redacted>
2. Error message as below is produced.
  
Actual results:
Unsupported server architecture error is returned, despite the fact that a
Fujitsu Solaris system is effectively no different than a Sun Solaris system.

Expected results:
Valid registration with the Satellite server.

Additional info:

bash-2.05# uname -m
sun4us
bash-2.05# rhnreg_ks --serverUrl=http://<redacted>/XMLRPC
--activationkey=<redacted> 

Error Message:
    Architecture `sparc-sun4us-solaris' is not supported
Error Class Code: 24
Error Class Info: Unsupported server architecture.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

bash-2.05#
Comment 1 Clifford Perry 2007-06-05 21:17:31 EDT
Hi,
 currently the Solaris support with Satellite is for hardware types:
sun4u
sun4m
i86pc

Any Solaris system installed on a hardware platform not of the above will
currently not work.

I have placed this bug under a tracker to triage for the next major product
release, beyond the Satellite 5.0 release. 

Regards,
Clifford
Comment 2 Carl Speare 2007-07-08 10:55:08 EDT
We did manage to modify the python code to fake a sun4u (instead of sun4us)
arch, and we even successfully imported a patch cluster and deployed it to a system.

Comment 3 Clifford Perry 2010-01-11 11:30:26 EST

*** This bug has been marked as a duplicate of bug 206998 ***

Note You need to log in before you can comment on or make changes to this bug.