Bug 242869 - Unable to analyze core generated from 2.6.21-23.el5rt using crash-4.0.3.14
Unable to analyze core generated from 2.6.21-23.el5rt using crash-4.0.3.14
Status: CLOSED DUPLICATE of bug 241726
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
All Linux
low Severity urgent
: ---
: ---
Assigned To: Red Hat Real Time Maintenance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 01:58 EDT by IBM Bug Proxy
Modified: 2008-02-27 14:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-07 14:59:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 35280 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-06-06 01:58:08 EDT
LTC Owner is: jstultz@us.ibm.com
LTC Originator is: ankigarg@in.ibm.com


Problem description:

The core dump generated from 2.6.21-23el5rt kernel when alnayzed using
crash-4.0.3.14, gave the following error:

# crash /var/crash/2007-06-06-00\:23/vmcore
/usr/lib/debug/lib/modules/2.6.21-23.el5rt/vmlinux 

crash 4.0-3.14
Copyright (C) 2002, 2003, 2004, 2005, 2006  Red Hat, Inc.
Copyright (C) 2004, 2005, 2006  IBM Corporation
Copyright (C) 1999-2006  Hewlett-Packard Co
Copyright (C) 2005  Fujitsu Limited
Copyright (C) 2005  NEC Corporation
Copyright (C) 1999, 2002  Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002  Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions.  Enter "help copying" to see the conditions.
This program has absolutely no warranty.  Enter "help warranty" for details.
 
GNU gdb 6.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu"...


crash: invalid (optional) structure member offsets: zone_struct_free_pages or
zone_free_pages
       FILE: memory.c  LINE: 11358  FUNCTION: dump_memory_nodes()

[/usr/bin/crash] error trace: 45b213 => 47d7c0 => 47ccd7 => 4f0007
/usr/bin/nm: /usr/bin/crash: no symbols
/usr/bin/nm: /usr/bin/crash: no symbols
/usr/bin/nm: /usr/bin/crash: no symbols
/usr/bin/nm: /usr/bin/crash: no symbols

WARNING: Because this kernel was compiled with gcc version 4.1.1, certain
         commands or command options may fail unless crash is invoked with
         the  "--readnow" command line option.


Using --readnow also results in the same error. There is no error when using
crash-4.0-4.1 and crash-4.0-4.2

So, it would be useful to have the newer crash rpm packaged with RHEL5RT.
Comment 1 Tim Burke 2007-06-07 14:59:32 EDT

*** This bug has been marked as a duplicate of 241726 ***
Comment 2 IBM Bug Proxy 2007-06-07 19:46:10 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|OPEN                        |ASSIGNED




------- Additional Comments From dvhltc@us.ibm.com  2007-06-07 19:41 EDT -------
Marking as fixed with the later version of crash.  Will mark as accepted once
RedHat includes in the repository. 
Comment 3 IBM Bug Proxy 2008-02-08 07:57:14 EST
------- Comment From ankigarg@in.ibm.com 2008-02-08 07:49 EDT-------
Sripathi, yes. The required version of crash tool is available in RHEL5.1. We
can close this bug.

Note You need to log in before you can comment on or make changes to this bug.