Bug 242967 - yum installer error
Summary: yum installer error
Status: CLOSED DUPLICATE of bug 241604
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 18:14 UTC by mahdi jamshidian
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 18:36:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mahdi jamshidian 2007-06-06 18:14:33 UTC
Description of problem:
when i choose multiple package in yum installer this error is occurred

Component: Software Manager
Summary: TB21f8f94d packages.py:485:getDiscNum:ValueError: invalid literal for
int() with base 10: ''

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 337, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 722, in
applyChanges
    dlpkgs = self.downloadPackages(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 417, in
downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 798, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 747, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 485, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''

Local variables in innermost frame:
self: libifp - 1.0.0.2-4.fc6.i386
netloc: 
fragid: 
path: //1180278169.239747
query: 
scheme: media

Comment 1 Jeremy Katz 2007-06-13 18:36:04 UTC

*** This bug has been marked as a duplicate of 241604 ***


Note You need to log in before you can comment on or make changes to this bug.