Bug 242979 - Installation Feature Requests (FutureFeature)
Installation Feature Requests (FutureFeature)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
: 242980 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 15:39 EDT by Tom Browder
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 13:12:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Browder 2007-06-06 15:39:30 EDT
FutureFeature

I have worked through MANY redhat and fedora installations over the years, most 
of them installing new over existing /boot, /, and swap partitions (I always 
protect my data on their own partition, /usr/local, which is not formatted).  
It has always been an irritant that a clean install defaults to completely wipe 
out one's data if not careful.  The menu has improved but I would I would like 
to see the following features for a standard Fedora install:

1.  If there are any linux partitions found, the default should be to customize 
the linux partitions.  Let the user change that if desired.

2.  During a custom partitioning selection, any existing partition label should 
be retained, even though the partition is formatted.
Comment 1 Chris Lumens 2007-06-07 10:49:34 EDT
*** Bug 242980 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2007-06-25 13:12:37 EDT
That then means that users end up defaulted to having to manually partition
rather than the default of automatically doing something reasonable.  Just
because the user has previously installed Linux doesn't mean that they want to
be confronted with doing custom partitioning by default.
Comment 3 Tom Browder 2007-06-29 19:55:23 EDT
It seems to me that the default for an installation program which finds an 
existing linux installation is to do no harm and default to asking for custom 
editing.

Note You need to log in before you can comment on or make changes to this bug.