Bug 242984 - Yum pulling rpm header same size of the rpm
Yum pulling rpm header same size of the rpm
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
i386 Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 15:50 EDT by Imtiaz Rahi
Modified: 2014-01-21 17:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-01 11:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Imtiaz Rahi 2007-06-06 15:50:25 EDT
Description of problem:
When downloading packages yum first pulls rpm headers.
The headers were supposed to contain small amount of data.
But the headers yum is pulling are of same size as the rpm itself.

Version-Release number of selected component (if applicable):
yum-3.0.6-1.fc6.noarch

How reproducible:
yum install/update <package>

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
$ sudo yum update apt synaptic 
Password:
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "allowdowngrade" plugin
Loading "protectbase" plugin
Loading "priorities" plugin
Loading "changelog" plugin
Loading "downloadonly" plugin
Setting up Update Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
0 packages excluded due to repository protections

1 packages excluded due to repository priority protections
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for synaptic to pack into transaction set.
synaptic-0.57.2-6.fc6.i38 100% |=========================| 1.6 MB    04:01     
---> Package synaptic.i386 0:0.57.2-6.fc6 set to be updated
---> Downloading header for apt to pack into transaction set.
apt-0.5.15lorg3.2-10.fc6. 100% |=========================| 979 kB    02:17     
---> Package apt.i386 0:0.5.15lorg3.2-10.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 apt                     i386       0.5.15lorg3.2-10.fc6  extras            979 k
 synaptic                i386       0.57.2-6.fc6     extras            1.6 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Total download size: 2.5 M
Downloading Packages:
(1/2): synaptic-0.57.2-6.  35% |========                 | 576 kB    03:07 ETA 
(1/2): synaptic-0.57.2-6. 100% |=========================| 1.6 MB    03:57     
(2/2): apt-0.5.15lorg3.2- 100% |=========================| 979 kB    02:38     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : apt                          ######################### [1/4] 
  Updating  : synaptic                     ######################### [2/4] 
  Cleanup   : synaptic                     ######################### [3/4]
  Cleanup   : apt                          ######################### [4/4]

Updated: apt.i386 0:0.5.15lorg3.2-10.fc6 synaptic.i386 0:0.57.2-6.fc6
Complete!
Comment 1 Seth Vidal 2007-06-07 08:34:28 EDT
Are you behind a proxy or transparent firewall?

Comment 2 Imtiaz Rahi 2007-06-08 04:41:17 EDT
I am behind a proxy (SQUID) set up on this machine on FC6.
There is a possibility that I am behind my ISP's transparent firewall.
Should proxy and or firewall create issues?
Note that it does not happen always, but I have seen this quite a few times
before this incident.
Thanks.
Comment 3 Seth Vidal 2007-06-22 00:39:18 EDT
yes, proxies will create these issues, frequently.

However, yum in fedora 7 no longer needs the rpm header so I'm going to close
this bug.
Comment 4 Imtiaz Rahi 2007-06-22 02:27:46 EDT
But still this issue is not solved in FC6 for which I reported this.
Hope to get a real solution for this.
Comment 5 Seth Vidal 2007-06-22 08:17:33 EDT
If you are behind a transparent proxy that does not support byte-ranges then
there isn't a lot that yum can do about it.
Comment 6 Imtiaz Rahi 2007-06-22 12:36:02 EDT
I am not behind any transparent proxy (my ISP does not have TP). I use my own
caching proxy server and thats not transparent.
Is there any config I can tweak in my caching proxy?
Comment 7 Seth Vidal 2007-07-01 11:13:09 EDT
make sure your server allows http 1.1 compliant byte-ranges.

alternatively you can only use ftp-based repositories.

Note You need to log in before you can comment on or make changes to this bug.