Bug 242988 - Xen can not pxe-boot paravirt guests
Xen can not pxe-boot paravirt guests
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
: FutureFeature, Triaged
: 443716 (view as bug list)
Depends On:
Blocks: 448899
  Show dependency treegraph
 
Reported: 2007-06-06 16:13 EDT by Guil Barros
Modified: 2010-10-22 11:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 07:25:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guil Barros 2007-06-06 16:13:44 EDT
Please provide support for pxebooting paravirt guests.
Comment 3 RHEL Product and Program Management 2007-10-15 23:58:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 RHEL Product and Program Management 2008-03-11 15:44:27 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 7 Daniel Berrange 2008-04-22 19:34:22 EDT
*** Bug 443716 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Berrange 2008-07-09 07:25:20 EDT
We have spent a significant amount of time trying to get the pypxeboot loader to
work even semi-reliably and failed on multiple occasions. PXE fundamentally
needs to be run from the context of the guest OS - paravirt boot process
fundamentally has to run from the Dom0 context. To make this work would require
creating fake Dom0 interfaces with the MAC address of the DomU, and getting PXE
client to attach to this interface rather than regular Dom0 one. In the unlikely
even that works, you're at the mercy of Dom0 network & firewall configuration.
pypxeboot is just a fundamentally flawed approach and cannot be made reliable
enough to consider for RHEL. Upstream Xen developers concurr & have rejected pxe
boot for paravirt.

Note You need to log in before you can comment on or make changes to this bug.