Bug 242997 - updatedb can't access fusefs_t/dosfs_t
updatedb can't access fusefs_t/dosfs_t
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 16:46 EDT by drago01
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 10:25:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2007-06-06 16:46:45 EDT
Description of problem:

I get this avcs in dmesg when updatedb runs:

audit(1181152309.499:12): avc:  denied  { read } for  pid=7267 comm="updatedb"
name="/" dev=sdc1 ino=1 scontext=system_u:system_r:locate_t:s0
tcontext=system_u:object_r:dosfs_t:s0 tclass=dir
audit(1181152309.499:13): avc:  denied  { read } for  pid=7267 comm="updatedb"
name="/" dev=sda1 ino=5 scontext=system_u:system_r:locate_t:s0
tcontext=system_u:object_r:fusefs_t:s0 tclass=dir


Version-Release number of selected component (if applicable):

selinux-policy-targeted-2.6.4-8.fc7

How reproducible:

always

Steps to Reproduce:
1. wait for the updatedb cron job to start
2. notice the errors in dmesg
3.
  
Actual results:

avcs

Expected results:

no avcs



Additional info:
audit2allow -d

#============= locate_t ==============
allow locate_t dosfs_t:dir read;
allow locate_t fusefs_t:dir read;
Comment 1 drago01 2007-06-22 10:25:34 EDT
this seems to be fixed ... dunno what was causing it.

Note You need to log in before you can comment on or make changes to this bug.