Bug 243018 - Multihead with Xinerama makes invisible barrier
Multihead with Xinerama makes invisible barrier
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 18:00 EDT by David Carlson
Modified: 2008-06-16 21:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing location of barrier (right 1/2 of right screen) (1.05 MB, image/png)
2007-06-06 18:00 EDT, David Carlson
no flags Details
xorg.conf, what worked on fc6 (2.22 KB, application/octet-stream)
2007-06-06 18:01 EDT, David Carlson
no flags Details
attached xorg log (from first xorg.conf) (63.10 KB, text/plain)
2007-06-21 21:45 EDT, David Carlson
no flags Details
generated (ish) xorg (1.32 KB, application/octet-stream)
2007-06-21 22:43 EDT, David Carlson
no flags Details
log (74.61 KB, application/octet-stream)
2007-06-21 22:44 EDT, David Carlson
no flags Details

  None (edit)
Description David Carlson 2007-06-06 18:00:56 EDT
Description of problem:
A multihead setup (that worked perfectly with Fedora 6) will on occasion create
an 'invisible barrier' that no window can cross.  See screenshot and xorg.conf.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-5.fc7

How reproducible:


Steps to Reproduce:
1. Log in
2. Start a Wine application
3. Attempt to put a window in the right 1/2 of right screen
  
Actual results:
Window is blocked by invisible barrier.  The barrier can be crossed by resizing
the window by its right side across the barrier.  Resizing the left side makes
the window freak out and retreat beyond the barrier.  Unfortunately, neither
byzanz nor istanbul can capture the behavior.

Expected results:
Window moves to right half of right screen

Additional info:
Comment 1 David Carlson 2007-06-06 18:00:57 EDT
Created attachment 156395 [details]
screenshot showing location of barrier (right 1/2 of right screen)
Comment 2 David Carlson 2007-06-06 18:01:50 EDT
Created attachment 156396 [details]
xorg.conf, what worked on fc6
Comment 3 Matěj Cepl 2007-06-10 19:22:25 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server log file (/var/log/Xorg.*.log) to the bug report as
individual uncompressed file attachment using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 David Carlson 2007-06-21 21:45:19 EDT
Created attachment 157590 [details]
attached xorg log (from first xorg.conf)
Comment 5 David Carlson 2007-06-21 22:43:23 EDT
Created attachment 157593 [details]
generated (ish) xorg

xorg from the 'autogenerated' run.  I started a new Xorg and went through the
GUI utilities to add the second head.  That doesn't work, so I implemented the
least amount of changes to get both displays up.  The problem still exists (and
is brought about by xrandr also)
Comment 6 David Carlson 2007-06-21 22:44:18 EDT
Created attachment 157594 [details]
log
Comment 7 David Carlson 2007-06-21 22:46:07 EDT
from the run with the 'generated' file, this problem is still here.  And
something happened that was telling:  A simple run of xrandr in either case
creates the invisible barrier.  I know the xrandr subsystem changed from fc6 ->
f7 - this is likely to be a side effect...
Comment 8 David Carlson 2007-06-27 00:38:37 EDT
I also ran into an invisible barrier when setting up another dual-head interface
with the new intel driver.

I start with the laptop output, and when I run:

xrandr --output VGA --mode 1600x1200 --left-of LVDS

it gives me the correct layout and resolution, but binds the cursor to an
1024x768 square within the 1600x1200 and doesn't allow any cursor movement to
the laptop panel.  Also I am upping this bug to high as it's affecting xrandr
with both heterogeneously (i810->mga) and homogeneously (intel).

I will probably file this with Xorg also.
Comment 9 Bug Zapper 2008-05-14 08:52:14 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2008-06-16 21:27:54 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.