Bug 243030 - closing laptop lid doesn't suspend system
Summary: closing laptop lid doesn't suspend system
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-06 22:42 UTC by Albert Bartok-Partay
Modified: 2008-01-09 23:45 UTC (History)
8 users (show)

Fixed In Version: 2.6.23.12-52
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 05:08:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
following the instructions given above, this is the output of 'gnome-power-manager --verbose --no-daemon' (13.03 KB, text/plain)
2007-06-06 23:04 UTC, Albert Bartok-Partay
no flags Details
output of '$ gnome-power-manager --verbose --no-daemon' (25.64 KB, text/plain)
2007-06-07 19:18 UTC, Albert Bartok-Partay
no flags Details
kernel patch (2.01 KB, patch)
2007-06-15 15:02 UTC, Richard Hughes
no flags Details | Diff

Description Albert Bartok-Partay 2007-06-06 22:42:56 UTC
Description of problem:
It happens quite often that I close the lid of my laptop (DELL latitude 600),
and the system doesn't suspend - in fact, nothing happens. After opening and
closing again, it suspends. Very peculiar. Further, it has happened twice so
far, and is quite worrying, that the system failed to return after suspension -
it was totally dead no X, no text terminals.

Version-Release number of selected component (if applicable):
2.18.0

How reproducible:
it happens quite often, but you can never tell if it will happen or not

Steps to Reproduce:
1. close laptop lid
2. open it 
3. close again
  
Actual results:
system doesn't suspend

Expected results:
system should suspend

Additional info:

Comment 1 Richard Hughes 2007-06-06 22:49:28 UTC
if you do:

killall gnome-power-manager
gnome-power-manager --verbose --no-daemon

Can you please attach the output after you closed the lid, waited 30 seconds,
then opened it again please. Thanks.

Comment 2 Albert Bartok-Partay 2007-06-06 23:04:23 UTC
Created attachment 156405 [details]
following the instructions given above, this is the output of 'gnome-power-manager --verbose --no-daemon'

Comment 3 Richard Hughes 2007-06-07 13:54:56 UTC
Thanks.

>[gpm_control_is_policy_timout_valid] gpm-control.c:127 (23:59:22): Skipping
suppressed policy event

Can you try setting /apps/gnome-power-manager/policy_suppression_timeout to 0 in
gconf editor and trying again? Thanks.


Comment 4 Albert Bartok-Partay 2007-06-07 19:18:41 UTC
Created attachment 156496 [details]
output of '$ gnome-power-manager --verbose --no-daemon'

unfortunately, still not works properly. what I've done:
# yum install gconf-editor
$ gconf-edit (required change done:
/apps/gnome-power-manager/policy_suppression_timeout=0
$ gnome-power-manager --verbose --no-daemon

what happened:
the first attempt: system suspended succesfully
2nd attempt: nothing happened
3rd attempt: system suspended succesfully again

(the log contains all these, I think)

Comment 5 Richard Hughes 2007-06-13 10:47:10 UTC
Odd. You only get 1 lid-up events, not 3.

Can you suspend, and then resume, and then do:

cat /proc/acpi/button/*/*/*

Also, run "sleep 5 && cat /proc/acpi/button/*/*/*" shut the lid, wait 10
seconds, and post the output. Also, "cat /proc/acpi/button/*/*/*" when you've
just opened the lid would be good.

Cheers.

Richard.


Comment 6 Albert Bartok-Partay 2007-06-14 08:53:05 UTC
here are the outputs:

> Can you suspend, and then resume, and then do:
> cat /proc/acpi/button/*/*/*
type:                    Lid Switch
state:      open
type:                    Power Button (CM)
type:                    Sleep Button (CM)

> sleep 5 && cat /proc/acpi/button/*/*/*" shut the lid, wait 10 seconds, 
type:                    Lid Switch
state:      closed
type:                    Power Button (CM)
type:                    Sleep Button (CM)

> cat /proc/acpi/button/*/*/*" when you've just opened the lid would be good.
type:                    Lid Switch
state:      open
type:                    Power Button (CM)
type:                    Sleep Button (CM)

can it be the problem that I upgraded my previous fedora 6 to fedora 7? I mean,
some rubbish just remained somewhere accidentally.

Comment 7 Richard Hughes 2007-06-15 15:02:26 UTC
Created attachment 157120 [details]
kernel patch

Found the problem, it was a kernel bug. The attached patch fixes it, and is
hopefully going to be in 2.6.22.

Comment 8 Albert Bartok-Partay 2007-06-16 10:38:13 UTC
Cool! I applied the patch to the kernel, and now it's perfect.

Comment 9 Richard Hughes 2007-06-16 10:41:27 UTC
Thanks for the quick testing. Could you add to the email thread the fact that it
works for you? Thanks.

Comment 10 Richard Hughes 2007-06-16 11:25:46 UTC
Dave, could you add this to the next build of fedora 7 updates please? I'm
hoping it's in time for .22, but it might have missed it.

Comment 11 Albert Bartok-Partay 2007-06-16 15:21:04 UTC
(In reply to comment #9)
> Thanks for the quick testing. Could you add to the email thread the fact that it
> works for you? Thanks.

Sorry, which email thread?

Comment 12 Richard Hughes 2007-06-16 17:14:03 UTC
It's okay, I've added to the lkml thread that this works for you, and that it
should try and get into .22. Fingers crossed.

Comment 13 Albert Bartok-Partay 2007-06-16 18:57:33 UTC
OK, I got it!

By the way, the system failed to resume again, as I mentioned in the 1st
comment. So it's suspended, and when I open the lid, the screen remain blank,
and nothing can be done... It doesn't even respond to CapsLock or NumLock
button. What I could save is a short part of /var/log/messages:

Jun 16 18:01:23 ab686 gnome-power-manager: (eger) Suspending computer because
the lid has been closed on ac power
Jun 16 18:18:53 ab686 restorecond: Read error (Interrupted system call)
Jun 16 18:18:53 ab686 gnome-power-manager: (eger) DBUS timed out, but recovering
Jun 16 18:18:53 ab686 gnome-power-manager: (eger) Resuming computer  
Jun 16 18:20:52 ab686 syslogd 1.4.2: restart.

Shall I create a new bug report or do you think this is still related to this
kernel bug?

Comment 14 Richard Hughes 2007-06-17 20:52:41 UTC
>It doesn't even respond to CapsLock or NumLock

Then you need to have a look here: http://people.freedesktop.org/~hughsient/quirk/


Comment 15 David Zeuthen 2007-06-18 16:28:33 UTC
-> kernel

Comment 16 Albert Bartok-Partay 2007-07-23 10:26:45 UTC
oh, my goodness, it does the same in the 2.6.22 kernel...

Comment 17 David Perkinson 2007-07-23 22:10:33 UTC
It seems the problem has not disappeared with kernel 2.6.22.1-27.fc7.
In order to get my ibm x40 to sleep, I must stillclose the lid twice. Otherwise,
power management seems to work fine.

Comment 18 bperkins 2007-09-01 14:36:09 UTC
2.6.22.4-65.fc7 still has this issue.
It goes away witht the patch.


Comment 19 Klaasjan Brand 2007-10-15 13:56:42 UTC
Still not fixed in 2.6.23 testing. (tested on Acer Travelmate 8000)


Comment 20 Ronald Kuetemeier 2007-11-10 01:37:48 UTC
FC8 same problem. Suspend manually works all the time.

Comment 21 Christopher Brown 2008-01-09 01:13:05 UTC
Has the patch managed to make it into the kernel yet?

Comment 22 Ronald Kuetemeier 2008-01-09 03:37:27 UTC
It's fixed in FC8. Check out bug: 275651. 

Comment 23 Jon Stanley 2008-01-09 05:08:38 UTC
Given that information, I'll go ahead and close this CURRENTRELEASE.

Comment 24 Chuck Ebbert 2008-01-09 19:48:13 UTC
Patch went in 2.6.23.9-43

Comment 25 Albert Bartok-Partay 2008-01-09 23:45:29 UTC
Took a while, didn't it? ;)


Note You need to log in before you can comment on or make changes to this bug.