Bug 243031 - viruskiller binary in the wrong directory
viruskiller binary in the wrong directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: viruskiller (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
: 243805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-06 19:04 EDT by Wart
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 12:41:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2007-06-06 19:04:14 EDT
Description of problem:
viruskiller generates selinux alerts:

avc: denied { read } for comm="prelink" dev=sda2 egid=0 euid=0
exe="/usr/sbin/prelink" exit=-13 fsgid=0 fsuid=0 gid=0 items=0
name="viruskiller" pid=4538 scontext=system_u:system_r:prelink_t:s0 sgid=0
subj=system_u:system_r:prelink_t:s0 suid=0 tclass=file
tcontext=system_u:object_r:usr_t:s0 tty=(none) uid=0 

This is because viruskiller is installed in the /usr/games directory, which is
not labeled as bin_t.  It should really be in /usr/bin.

Additionally, the /usr/share/games/viruskiller directory is better located in
/usr/share/viruskiller.

This could also be fixed by labeling the files in /usr/games as bin_t, but I
think moving the executable to /usr/bin is a better solution.

Version-Release number of selected component (if applicable):
viruskiller-1.0-3.fc7
Comment 1 Matthias Saou 2007-06-12 04:24:19 EDT
*** Bug 243805 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Saou 2007-06-14 11:09:55 EDT
I've rebuilt a "fixed" package for devel, which you can try :
http://koji.fedoraproject.org/koji/taskinfo?taskID=36426

Next, I'll push updates for FC6 and F7.
Comment 3 Fedora Update System 2007-06-16 09:21:10 EDT
viruskiller-1.0-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Jim Cornette 2007-06-17 01:25:59 EDT
It works fine now
Comment 5 Fedora Update System 2007-06-18 12:41:42 EDT
viruskiller-1.0-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.