Bug 243053 - Server reboot in Sydney/Australia timezone causes udev to create files in future
Summary: Server reboot in Sydney/Australia timezone causes udev to create files in future
Status: CLOSED DUPLICATE of bug 230997
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-07 03:34 UTC by Doug Scoular
Modified: 2008-01-14 16:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 16:55:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of devices and timestamps in /dev created around Thu Jun 7 12:40:58 EST 2007 (20.98 KB, application/octet-stream)
2007-06-07 03:34 UTC, Doug Scoular
no flags Details

Description Doug Scoular 2007-06-07 03:34:45 UTC
Description of problem:
Rebooting a server causes entries in /dev to be created with a timestamp
set in the future e.g. /dev/null.

[root@eng-syd-022 sysconfig]# ls -l --full-time /dev/null
crw-rw-rw-  1 root root 1, 3 2007-06-07 23:07:19.758820480 +1000 /dev/null
[root@eng-syd-022 sysconfig]# date
Thu Jun  7 12:40:58 EST 2007
[root@eng-syd-022 sysconfig]# hwclock
Thu 07 Jun 2007 12:41:09 PM EST  -0.899664 seconds


Version-Release number of selected component (if applicable):
[root@eng-syd-022 sysconfig]# rpm -q udev
udev-039-10.15.EL4

How reproducible:
Set the timezone to Australia/Sydney, ensure the hardware clock
is set to localtime .e.g. 

[root@eng-syd-022 sysconfig]# more /etc/sysconfig/clock
ZONE="Australia/Sydney"
UTC=false
ARC=false


Steps to Reproduce:
1. Reboot server
2. Compare current time with timestamp on /dev/null and friends.
3. timestamp should be in the future.
  
Actual results:
root@eng-syd-022 sysconfig]# ls -l --full-time /dev/null
crw-rw-rw-  1 root root 1, 3 2007-06-07 23:07:19.758820480 +1000 /dev/null

Expected results:
A timestamp for /dev/null that is NOT in the future!

Additional info:
This is completely repeatable. I have created a vmware instance, removed
/dev/null just prior to a reboot and udev still creates /dev/null with a
timestamp in the future.

Comment 1 Doug Scoular 2007-06-07 03:34:45 UTC
Created attachment 156421 [details]
list of devices and timestamps in /dev created around Thu Jun  7 12:40:58 EST 2007

Comment 3 Bill Nottingham 2008-01-14 16:55:46 UTC
This sounds like a duplicate of bug 230997, fixed in a later initscripts build
for RHEL 4.

*** This bug has been marked as a duplicate of 230997 ***


Note You need to log in before you can comment on or make changes to this bug.