Bug 243130 - Full lvm snapshots cause corruption in lvm metadata leading to kernel panics.
Full lvm snapshots cause corruption in lvm metadata leading to kernel panics.
Status: CLOSED DUPLICATE of bug 244215
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-07 09:53 EDT by Brenton Leanhardt
Modified: 2013-02-28 23:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 04:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2007-06-07 09:53:24 EDT
Description of problem:
Two times this week I have made lvm snapshots too small for my xen guests.  When
they became full my Xen Dom0 had a kernel panic and rebooted.  On reboot kernel
panics again and shows errors related to lvm metadata.  The way I fixed it the
first time was to boot into rescue mode and remove the full logical volume
snapshot. 

Version-Release number of selected component (if applicable):
2.6.18-8.1.4.el5xen and 2.6.18-8.1.4.el5
lvm2-2.02.16-3.el5

Additional Info:
Please let me know what other information I can provide to help the debugging
process.  I have left the machine in the state of lvm metadata corruption in the
event that something can be salvaged from it providing useful information. 
Unfortunately, I will need to kickstart the machine in a day or two though so
let me know as soon as possible if I can help track this down.
Comment 1 Milan Broz 2007-06-10 05:21:33 EDT
I can imagine that kernel with mounted fs on invalidated snapshot will panic
because of strange error (snapshot is full -> all running IO will fail -> it can
lead to unexpected situation e.g. in fs code...).
But this is not case for Dom0 - please could you provide panic log (backtrace
and syslog) of this system ? Was it really snapshot invalidation or any other
bug in kernel leading to panic ?

Also please attach some lvm info - the best is use lvmdump command and attach
created archive. If possible, attach boot message with invalid metadata errors too.
Comment 2 Milan Broz 2007-07-30 04:48:19 EDT
OK, there was another problem with activating full snapshots after reboot, which
is now fixed (in kernel) - closing this as duplicate.

So now even if guests overfill snapshot system should remain bootable (no rescue
mode needed).

Please if you hit some metadata corruption again, reopen this bug and attach
debugging information (at least output of lvmdump command). Thanks.


*** This bug has been marked as a duplicate of 244215 ***

Note You need to log in before you can comment on or make changes to this bug.